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Chapter 1IntroductionThere are a number of systems for describing the development of graphical user interfaces(GUIs) in a lazy functional language; examples include Fudgets [9], Gadgets [16], and Haggis[6]. All of the designers of these systems have had to grapple with similar issues, such as howto perform side e�ecting I/O in a purely functional language, and how to provide a structuredinterface to the event driven model of windowing systems. However, the main research thrustof these systems is in the abstractions they provide for the construction of GUIs. In this report,we describe a framework that encapsulates the common elements of some of these systems,and consists of layers, each building on top of the functionality provided by the lower layers.Two high-level systems for constructing GUIs have been built on the framework, based onHaggis and Fudgets respectively.The Embracing Windows1 framework has been developed using the Hugs functional pro-gramming system [10] and currently interfaces to Windows 952. The examples in this reportassume familiarity with Haskell 1.3 [17].In the remainder of this chapter, we discuss the lowest layer in the framework, concerningI/O in a purely functional language. Chapter 2 details the next layer, which encapsulatesa basic interface to a window system. In Chapters 3 and 4 we describe the two high-levelsystems for constructing GUIs that have been built on the framework. Chapter 5 summarisesthese two systems and brie
y describes how they can be used together. Finally we conclude inChapter 6 with a survey of related work, and also present some ideas for future investigation.The appendices present a number of extended example applications built with the high-levelsystems described in Chapters 3 and 4. The Haskell source code of the framework is alsoincluded in the appendices.1.1 I/O in Purely Functional LanguagesThis section discusses I/O in purely functional languages, which form a basis for the particularform of I/O required by GUIs. A �rst attempt at I/O in a functional language might be toprovide side e�ecting primitives similar to I/O functions in imperative languages such as C:getChar :: CharputChar :: Char -> ()1The Embracing Windows framework is available from http://www.cs.nott.ac.uk/~cjt/EW.html2Windows 95 is a registered trademark of the Microsoft Corporation5



The getChar function waits for a key to be pressed and returns the corresponding character,while putChar c prints the character given as its argument, c, on the display. However,primitives like these limit the ability to use simple equational reasoning and program trans-formation due to the loss of referential transparency. The result of a referentially transparentfunction should depend purely upon its arguments. Every time getChar is called it couldpotentially return a di�erent value, thus destroying referential transparency, for example:x == x where x = getChar 6= getChar == getCharThese expressions are not equivalent because the result of the side e�ecting primitives isshared, rather than sharing the actions that the side e�ecting primitives perform.A number of di�erent approaches to handling I/O in functional languages that solve theseproblems have been proposed:� Streams. A stream is a lazy list of data objects. Miranda3 [24], Ponder [4] and Hope [2]use streams for I/O. In these systems, an interactive program is modelled as a functionfrom one stream representing the input, to another representing the output.� Continuations. Continuation passing style entails writing functions that take an extraargument, a continuation, describing what to do next. Instead of the function returningits result directly, it is passed on to the continuation to be processed �rst. A usefulproperty of continuations is their ability to specify an order of evaluation [18]. This canform the basis for a model of I/O using side e�ecting primitives.� Monads. Motivated by the work of Moggi [13] and Spivey [23], Wadler [27, 26] proposeda style of functional programming based on monads that can be used to model impure`features' such as input and output. Monadic I/O [11] uses a collection of combinatorsto build interactive programs from primitive actions. When the program is executed,these actions are performed, realizing the I/O. Monadic I/O is used as the mechanismfor I/O in Haskell 1.3 [17].1.2 MonadsThe use of monads is now established as a method for describing interactive programs, andwill be used as the mechanism for I/O throughout this report. Our original example can bedescribed using the IO monad as:getChar :: IO CharputChar :: Char -> IO ()The result of the putChar function is an action that prints a character on the display. Simi-larly, the result of getChar is an action that reads a character from the keyboard. Monadiccombinators are used to combine actions together:returnIO :: a -> IO athenIO :: IO a -> (a -> IO b) -> IO b3Miranda is a trademark of Research Software Ltd.6



The returnIO combinator constructs a trivial action that has no side e�ects, and whosereturn value is the �rst argument of the combinator. a `thenIO` f, when performed, will�rst perform the action a, applying the result to the function f to obtain a further action.This latter action will be performed next and the value returned by this action is the resultof the expression a `thenIO` f. A monad is simply an abstract data type, speci�ed by atype constructor, m, which supports two operations whose types are the same as the types ofthe functions returnIO and thenIO with the type constructor IO replaced by m. A monadmay also support other operations as well. Three algebraic properties must be satis�ed bythe two operations, but we do not concern ourselves further with these properties in thisreport. Together the data type IO and the monadic combinators returnIO and thenIO forma monad.The type constructor IO can be thought of as being de�ned as:type IO a = World -> (a, World)Here, a value of the type World represents the state of the `real world', such as the contentsof a �le system, pictures displayed on a screen, and characters read from a keyboard. Thisde�nition is not visible to the programmer and is built into the system as a primitive type.However, it allows us to see why monads restore the referential transparency that our side-e�ecting primitives lacked. Expanding out the de�nition of IO Char in the type of the getCharfunction gives:getChar :: World -> (Char, World)The return value of this function contains the character pressed and the new state of the world.It is also clear that the character pressed depends upon the initial state of the world, whichis the �rst argument to the function. The result of the function thus depends purely uponits argument, and so maintains referential transparency. We are also free to use equationalreasoning, as an expression of type IO a represents an action rather than the result of aside-e�ecting operation. An action can be shared like any other �rst class value, and is onlyturned into a side-e�ecting operation when the program is executed.The abstract data type that forms the IO monad essentially prevents the world from beingduplicated. This allows us to optimise operations such as getChar to update the value ofthe world in place, rather than creating a copy of the initial value of the world, modi�edaccording to the operation being performed. This results in an e�cient implementation of IOthat still maintains referential transparency.Using these combinators, we can describe a function that will, print a string on thedisplay:putString :: String -> IO ()putString [] = returnIO ()putString (c:cs) = putChar c `seqIO`putString csThe seqIO combinator is similar to thenIO, except that it discards the result of the actionspeci�ed by its �rst argument, and only requires an action rather than a function as its secondargument. The seqIO combinator can be de�ned in terms of thenIO as:seqIO :: IO a -> IO b -> IO ba `seqIO` b = a `thenIO` (\_ -> b)7



The two combinators, returnIO and thenIO are speci�c cases of combinators that are re-quired for a data type to be a monad. The standard prelude of Haskell 1.3 includes a type classspeci�cally for representing monads called Monad. This type class supports three overloadedfunctions, return, >>=, and >> corresponding to returnIO, thenIO and seqIO, respectively.Haskell 1.3 also provides a syntactic convention for expressing functions using monadic com-binators, called do notation. Using this syntax, the putString function previously examinedcan be rewritten as:putString :: String -> IO ()putString [] = return ()putString (c:cs) = do putChar cputString csThe remainder of this report will make use of this syntactic convention, which expressesmonadic functions more concisely.
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Chapter 2Interfacing to a Window SystemIn this chapter, we present the core of the Embracing Windows system. The structure ofthe core is split into �ve main layers that can be seen in Figure 2.1. We �rst present anintroduction to the concepts involved in modern windowing systems, followed by a descriptionof each of the �ve main pieces comprising the core.2.1 Modern Window SystemsMost modern windowing systems allow the user to run multiple applications, with the userswitching between applications at will. Such systems are driven by the order of events becausethe input to applications is essentially interleaved. An event can correspond to externalstimuli, such as mouse clicks, or keyboard input, but can also signal an internal operationsuch as the creation or destruction of a window. The dispatching of events to the appropriateapplication is handled by the windowing system. Conventionally, applications that are to beused in such a system are built around an event loop that processes events. An event loopcan be modelled functionally as a stream processor. Such a stream processor transforms alist of events into a list of actions by mapping an appropriate event processing function overthe list of events.Windowing systems encapsulate the environment for drawing graphics in a special struc-ture, commonly referred to as a graphics or device context. This includes information such asthe current drawing colour, width and shape of pen, and brush type for �lling areas. Whenan application draws in a window, it must �rst obtain an appropriate device context. Alldrawing operations require the device context as a parameter. Finally, when the applicationhas �nished drawing it must relinquish the device context to the windowing system.2.2 Monadic PrimitivesNon-graphical interactive programs use primitives that write characters to the display andthat read characters from the keyboard. A graphical interactive program requires I/O prim-itives in a similar way to a non-graphical interactive program. However, the primitives willdraw lines in windows, and read clicks from mouse buttons. Instead of reading charactersdirectly from the keyboard, a primitive will supply the characters typed when the input fo-cus is on the application's window. Similarly, instead of writing characters to the display, aprimitive will display a character in one of the application's windows.9
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Figure 2.1: The core of the Embracing Windows systemThe monadic putChar and getChar functions provided appropriate primitives for func-tional programs to interact with a console. In a similar manner, we can de�ne primitives thatare appropriate for graphical interactive programs. In the Embracing Windows frameworkthere are three groups of primitives:� Event loop operations� Basic window operations, such as creating, and destroying windows.� Graphic operations, such as drawing lines, and changing pen colours and sizes.We can use type classes to provide an interface to such primitives (see Figures 2.2 and2.6). The advantage of using type classes is that we can abstract from the monad that theprimitives are de�ned in. This becomes useful when we need to use the primitives in monadsother than the monad that they are originally implemented in. Another advantage of usingtype classes is that they structure the world e�ectively. Instead of considering the world asa single entity we can think of it as being comprised of subworlds, such as an event system,a windowing system, and a drawing system, which in turn may consist of more subworldsthemselves. This structure is made evident in the type system by the use of type classes.The Clean language structures the world in a similar way [1] and claims that this avoidsthe speci�cation of ordering between I/O involving separate parts of the world. When twoindependent subworlds are being manipulated then the order in which they are changed isirrelevant, and the underlying implementation of the language can decide which order to use.The type of a function using the monadic primitives will include a context which expressesprecisely the components of the world used, such as event loops, basic window operations, orgraphics operations.The �rst group of primitives characterises event-driven applications and are de�ned inthe EventSystem type class. The second group of primitives characterises applications withwindow based interfaces and are de�ned in the WindowSystem type class. The last group ofprimitives characterises applications that draw graphical pictures in windows, and these prim-itives are described in Section 2.6.1. An instance of both the EventSystem and WindowSystem10



class Monad m => EventSystem m whereeventLoop :: (Event -> IO Int) -> m () -- Starts an event loopdefaultHandler :: Event -> m Int -- A default event handlerquitEventLoop :: m () -- Terminate event loopclass EventSystem m => WindowSystem m wherecreateShellWindow :: String -> m Window -- Creates a shell windowdestroyWindow :: Window -> m () -- Destroys a windowsetWindowCaption :: Window -> String -> m () -- Set window captiongetWindowCaption :: Window -> m String -- Get window captionsetWindowRect :: Window -> Rect -> m () -- Set window sizegetWindowRect :: Window -> m Rect -- Get window sizegetWindows :: m [Window] -- Get open windowsshowWindow :: Bool -> Window -> m () -- Set window visibilityFigure 2.2: Window system primitivestype classes is required for the IO monad, with the implementations of the methods simplybeing the monadic primitives built-in to the functional language:instance EventSystem IO where...instance WindowSystem IO where...The full instance declarations are de�ned in Appendices B.1.5 and B.1.6. An example of anapplication that may be event-driven, but not use a window based interface, is a networkdatabase server. In a similar way that the window operations of the WindowSystem type classare layered on the event-driven operations of the EventSystem type class, one could imaginede�ning a type class encapsulating networking operations.We can proceed to create monadic functions that give the functional programmer access toall of the functionality of windowing systems that is available to the imperative programmer.However, handling input in windowing systems becomes more involved; modern windowingsystems support the use of multiple applications simultaneously, and input to the di�erentapplications can be interleaved arbitrarily by the user. We will return to this issue in Sec-tion 2.3.2.2.1 TypesAs well as requiring built-in primitives to access the functionality of a window system, built-intypes are required. These types are used to represent windows, objects for drawing graphicssuch as pens and brushes, and device contexts encapsulating the current drawing environ-ment:data Windowdata Objectdata DC 11



Vectors, represented as pairs of integers are used very frequently when constructing aGUI, to describe positions, sizes, and rectangles. We de�ne type synonyms to make the useof vectors clear:type Vector = (Int, Int)type Point = Vectortype Size = Vectortype Rect = (Vector, Vector)A disadvantage of using type synonyms is that a value representing a point could be usedin the context where a size was expected. Such an inconsistency would not be detected as atype error. This problem could be solved by using datatypes, but would require the insertionof the names of appropriate data type constructors.Events that occur in a windowing system are represented by values of the type Event.The de�nition of this type is speci�c to a windowing system (Section 2.9.1 de�nes an Eventtype for Windows 95). In general, events can be classi�ed by the type of the event, such asmouse button click, key press, or creation of a window. It will be useful to determine thetype of an event and, for this purpose, we de�ne a function, getEventType, and an associateddatatype specifying a domain of event types:data EventType = ...getEventType :: Event -> EventTypeThe exact implementation of this type and function are dependent upon the windowing systembeing used. However, it is important that we have a set of values that can be used to representthe types of events.2.3 Event LoopsConsidering an interactive application as a stream processor taking a list of events to anaction, and describing this by mapping a function over the list of events leads to a possibleimplementation:event_loop :: (Event -> IO ()) -> [Event] -> IO ()event_loop handle_event = sequence . map handle_eventThe processing of each individual event results in an action of type IO (), and all of theseactions are combined sequentially into one single action using sequence, which is a standardHaskell 1.3 function. We can make use of the primitive functions for performing windowingoperations, such as drawing lines in windows, in response to events. The handle eventfunction de�nes the behaviour of the application in response to events.The event Loop function described above makes the list of events explicit; in practice alist is not used as only one event can happen at a time. The eventLoop primitive functionsin an imperative manner, waiting for an event to happen and then calling the event handlingfunction speci�ed by its �rst argument to process this event, and then waiting for the nextevent, and so on. A list of actions is generated, each one corresponding to the appropriateresponse for an event, but all these events happen sequentially, and so again an explicit listis not required as the actions can be performed when the events occur. The event handling12



main :: IO ()main = do window <- createShellWindow "Test GUI"showWindow True windoweventLoop defaultHandlerFigure 2.3: A simple graphical applicationfunction can specify default behaviour in response to an event, by passing the event to thewindowing system using the default event handler, defaultHandler. Finally, a functionalprogrammay want to halt the event loop and can do so by using the quitEventLoop primitive.An application with a simple GUI can now be constructed that creates a window andstarts an event loop, passing every event to the default event handler (see Figure 2.3). Bydefault the createShellWindow function does not make the new window visible, and so theshowWindow primitive must be used to make it visible.2.4 Message CrackingThe Event datatype is used to encapsulate information about any event that may occurin the system. Unfortunately, this means that information pertaining to the event may bepacked into the event data structure, and needs to be unpacked before it can be used. Thepacking algorithm depends on the type of event, and we would like the unpacking to be doneautomatically for the programmer. The unpacking of this information is commonly referredto as message cracking. Ideally, we would like the programmer to be able to write functionsthat deal with the unpacked data explicitly. For example, the programmer could write afunction such as:processLButtonDown :: Vector -> IO ()to specify the behaviour of the application in response to the left mouse button being pressed.The �rst argument to this function represents the position of the mouse pointer when the leftmouse button was pressed. However, this function is not an event handler. To turn it intoan event handler, we can use a coercion function such as:handleLButtonDown :: (Vector -> IO ()) -> Event -> IO ()This function manages the unpacking of information from an event, and passes the unpackedinformation to its �rst argument to handle the event. Now the programmer can handle a singleevent in a structured fashion by using a combination of such functions, for example:myEventHandler :: Event -> IO ()myEventHandler = handleLButtonDown processLButtonDownThe coercion functions are provided as a library for use by the programmer (Appendix B.2.2),allowing the programmer to write functions describing the behaviour of their applicationwithout being concerned about the packing of event information into the event data type.13



2.5 Building Event HandlersAn application may, in general, be interested in many di�erent types of events, giving di�erentbehaviour in each case. Such behaviour could be created by using combinators to combineevent processing functions. One of the disadvantages of using combinators is the di�culty ofexpressing the deletion of a behaviour; the usual solution is to use a combinator to composea function that overrides the existing behaviour. When specifying the initial behaviour of aGUI combinators su�ce, but the behaviour of a GUI may change as the application executes.Combinators do not seem to be particularly natural to express this change in behaviour, asit is not often that the response to an event is incremently changed, instead it is usually justreplaced entirely. For this reason, the Embracing Windows framework uses a datatype torepresent behaviour, as replacing existing behaviour is simply a matter of replacing one valueof the datatype with a di�erent value.Since events are associated with a particular window, we may also want di�erent behaviourfor di�erent windows. We can model this by using a table whose entries specify the behaviourfor speci�c windows. The behaviour of a speci�c window can also be modelled by a tablewhose entries determine the responses to speci�c events. A desirable property is for thebehaviour of an application to be able to be altered in response to events.2.5.1 The GUI MonadThe tables required to specify the behaviour of an application can be implemented function-ally. However, this requires that the state be passed explicitly to all functions that may accessor modify the state. To avoid having to plumb the state through the system, we can hidethe details by using a monad. The monad must be an extension of the IO monad so that wecan still make use of the monadic primitives from Figure 2.2. Extending the IO monad withstate transformer capabilities allows us to make the plumbing of the state implicit. However,it was originally thought that using the well known formulation of state transformers, s ->(s, a), would complicate the event loop primitives. An alternative to using the standardformulation of state transformers is to use an IO monad with state reader capabilities, wherethe state is stored in a mutable variable, Ref s -> IO a. An interesting question is whethersuch a monad is equivalent to the conventional state transformer monad; intuitively, at least,it seems that these two approaches should be equivalent.Mutable variables provide a mechanism to mutate state in such a way that the changescan be implemented by updating the state in-place. A mutable variable has a type Ref a,and is a reference to a piece of state containing a value of type a. The state contains amapping from references to values. Operations on mutable variables are allocation, reading,and writing:newRef :: a -> IO (Ref a)getRef :: Ref a -> IO asetRef :: Ref a -> a -> IO ()The mutable variables used here are embedded in the IO monad, so that they can be usedin the context of the primitive window functions such as createShellWindow. The functionnewRef takes an initial value and returns an action that creates a new reference, bound tothe initial value, and that returns the reference as its result. Given a reference v, getRef vis an action that performs no side-e�ects, but uses the state to map the reference to its value.The function setRef is an action that modi�es the state so that it maps the reference to a14



class Monad m => MutVars m wherenewRef :: a -> m (Ref a)getRef :: Ref a -> m asetRef :: Ref a -> a -> m ()Figure 2.4: Mutable variable primitivesnew value. It is useful to create a type class encapsulating the operations that characterisemutable variables. This allows the same name to be used for the operations independent of theparticular monad they are being used in. The type class can be seen in Figure 2.4. An instanceof this type class for the IO monad is implemented using the built-in primitives for mutablevariables in the Hugs system (the instance declaration is shown in full in Appendix B.1.7).The Embracing Windows framework captures the behaviour of an application as the statein a state reader monad. This state stores a reference to the tables that specify the responsesof the application to particular events:type GUIState = WindowTabletype GUIStateVar = Ref GUIStatenewtype GUI a = GUI (GUIStateVar -> IO a)Appropriate unitGUI and bindGUI functions can be de�ned, and used to de�ne GUI as aninstance of the Monad type class. Instances of the EventSystem, WindowSystem and MutVarstype classes can also be de�ned by using the liftGUI function that lifts an operation fromthe IO monad to the GUI monad:liftGUI :: IO a -> GUI aliftGUI a = GUI (\_ -> a)instance EventSystem GUI whereeventLoop handler = liftGUI (eventLoop handler)...instance WindowSystem GUI wherecreateShellWindow title = liftGUI (createShellWindow title)...instance MutVars GUI wherenewRef init = liftGUI (newRef init)...The entire instance declarations for the EventSystem and WindowSystem type classes can beseen in Appendix B.2.4, and for the MutVars type class in Appendix B.2.1.An application is composed of three main steps, �rstly the state for the GUI monad mustbe initialised to specify default behaviour that will be provided by the windowing system.Secondly, the interface for the application must be created along with the speci�c behaviour15



of the interface components. Finally, the event loop is started allowing events to be receivedand processed according to the behaviour speci�ed by the previous steps. These steps aremodelled by the startProg function:startProg :: GUI a -> IO ()startProg w = do st <- newVar initGUIStatestartingWithGUI st weventLoop (mainHandler st)The interface is speci�ed by the argument to the startProg function, and is used to creategraphical components and add entries specifying their behaviour to the state encapsulatedby the GUI monad. The initGUIState function returns an initial value for this state whichdefers all behaviour to the windowing system. The mainHandler function takes a referenceto the state encapsulated in the GUI monad so that the response to an event for a particularwindow can be determined. The event handler determining the response is retrieved from thetables which form this state, by looking up the appropriate window and event type. This isperformed by the processEvent function (see Section 2.5.2 for details of the lookupHandlerfunction), which also passes the event to the retrieved event handler for processing:mainHandler :: GUIStateVar -> Event -> IO ()mainHandler st event = startingWithGUI st (processEvent event)processEvent :: Event -> GUI ()processEvent event = do handler <- lookupHandler eventhandler eventUsing the GUImonad, event handlers can be built as functions returning values of type GUI ()rather than type IO (), thus allowing the event handlers to modify the tables describing thebehaviour of the application. The family of coercion functions, such as handleLButtonDownneed to be changed to work in the GUI monad:type EventHandler = Event -> GUI ()handleLButtonDown :: (Vector -> GUI ()) -> EventHandler2.5.2 The GUI StateThe behaviour of an application is stored in a table, indexed by values of type Window. Thisallows di�ering behaviours to be speci�ed for each window. The entries in the table are tablesthemselves, indexed by the type EventType, with entries that are event handlers describingthe actual responses:type WindowTable = Table Window EventHandlerstype EventHandlers = Table EventType EventHandlerWe would like to use event processing functions, such as processLButtonDown as the entriesin tables of type EventHandlers. However, di�erent event processing functions have di�erenttypes because the information they unpack from the event depends entirely upon the typeof the event. By using functions like handleLButtonDown we can turn the event processingfunctions into event handlers which have one type and so can be used as entries in tablesof type EventHandlers. We will, of course, need mechanisms to lookup and remove entriesfrom such a table, for example: 16



main :: IO ()main = startProg simplesimple :: GUI ()simple = do window <- createShellWindow "Simple"showWindow True windowaddHandler window LButtonDown (ldown window)addHandler window Key (keydown window)ldown :: Window -> Event -> GUI ()ldown window _ = setWindowCaption window "Left mouse button pressed"keydown :: Window -> Event -> GUI ()keydown window _ = do removeHandler window LButtonDownsetWindowCaption window "Key pressed"Figure 2.5: A simple application illustrating event handlingaddHandler :: Window -> EventType -> EventHandler -> GUI ()removeHandler :: Window -> EventType -> GUI ()lookupHandler :: Event -> GUI EventHandlerThe addHandler function takes a window, an event type and a handler for these types ofevents, and modi�es the state encapsulated by the GUI monad to include the new eventhandler. The removeHandler function takes a window and an event type, and modi�es thestate encapsulated by the GUImonad to remove the event handler for the speci�ed event type.The lookupHandler function can be used to obtain the appropriate event handler for a givenevent passed to it as its argument. If no event handler exists for the event, then a reasonablecourse of action is to return the default event handler.2.5.3 A Simple Event HandlerFigure 2.5 shows an example of using these functions to set up responses to particular eventsthat alter the title text of a window when either the mouse is pressed or a key is pressed. Whenthe mouse is pressed, this application changes the title text of the main window, however ifa key is pressed then the title text is changed to re
ect this and also the response to mouseclicks is changed so that nothing happens. This example illustrates how applications canhandle multiple types of events, and also how the responses to these events can be changedas a program executes.2.5.4 A Better InterfaceEvent handlers may modify the behaviour of the application through the use of the addHandler,and removeHandler functions. A slightly easier interface for the programmer can be con-structed by de�ning specialised functions for de�ning the behaviour of an application inresponse to particular events. For example, to specify the behaviour required when the leftmouse button is pressed down we can use the following function:17



class WindowSystem m => DrawingSystem m wherelineTo :: Point -> m ()moveTo :: Point -> m ()selectObject :: Object -> m ObjectdeleteObject :: Object -> m BooldrawText :: Point -> String -> m ()createPen :: Int -> Colour -> m ObjectFigure 2.6: Drawing primitivesonLButtonDown :: Window -> (Vector -> GUI ()) -> GUI ()onLButtonDown window handler= addHandler window LButtonDown (handleLButtonDown handler)Functions can be de�ned for other types of events in a similar manner. The other functionsare shown in Appendix B.3.2, which also illustrates that in practice the argument of thehandler function will expect more arguments than just a Vector. The arguments to thehandler function depend upon the particular event.2.6 Drawing Graphics2.6.1 Graphic PrimitivesJust as we introduced primitives for supporting event loops and basic window operations, weintroduce appropriate primitives for drawing in windows. The primitives can be characterisedby a type class that abstracts away from the monad the primitives are originally implementedin, similarly to the EventSystem and WindowSystem type classes. In the Embracing Windowsframework, we opt to support only a handful of the possible operations that a windowingsystem supports for drawing graphics, and de�ne the DrawingSystem type class to encapsulatethem (Figure 2.6).Instead of de�ning an instance of this type class for the IO monad, as we did for theEventSystem and WindowSystem type classes, we need to de�ne a new monad, the Drawmonad. The primitive drawing operations require a device context parameter not evident inthe methods of the DrawingSystem type class, and this is exactly what will be supplied bythe Draw monad. This method has been used in a declarative toolkit for programming GUIsusing the ML language [19].2.6.2 The Draw MonadThe process of drawing graphics in a window involves obtaining a device context, whichencapsulates the environment for the drawing, such as the current colour, pen size and penshape. It is cumbersome to have to obtain a device context before drawing, and furthermorethe device context has to be passed to all of the primitive drawing operations. This can beavoided by using the same technique used to hide the details of the state storing the behaviourfor events in the GUI monad. We can de�ne a drawing monad, Draw, that hides the device18



context being used. Since the drawing operations never directly modify the device contextthe type of monad we require is a state reader monad:newtype Draw a = Draw (DC -> GUI a)instance Monad Draw wherereturn x = Draw (\dc -> return x)Draw g >>= f = Draw (\dc -> do a <- g dclet Draw h = f ah dc)The Draw monad supports operations that require a device context and that operate in theGUI monad. An operation in the IO monad can easily be handled by using the lifting func-tion for the GUI monad, liftGUI. We are now in a position to declare an instance of theDrawingSystem type class for the Draw monad which will hide all of the details of devicecontexts. For each of the methods in the DrawingSystem type class we provide an implemen-tation in terms of the appropriate primitive functions lifted from the IO monad to the GUImonad:instance DrawingSystem Draw wherelineTo (x, y) = Draw (\dc -> lift (primLineTo dc x y))...The entire instance declaration can be seen in Appendix B.3.4. The Draw monad hides thedetails of the device context, but does not yet allow us to make use of this. We need afunction that supplies the initial device context, equivalent to the value of the world suppliedto a program written using the IO monad by executing the program:startingWithDC :: DC -> Draw a -> GUI astartingWithDC dc (Draw d) = d dcAn application can draw in a window by simply obtaining an appropriate device contextand then supplying this to the startingWithDC function along with a value of type Draw adescribing the drawing to take place. For arbitrary drawing, we de�ne the drawInWindowfunction which takes a reference to the window to draw inside of as its �rst argument. Itssecond argument de�nes the drawing to be undertaken, while its result is the correspondingvalue of type GUI a that will perform the drawing:drawInWindow :: Window -> Draw a -> GUI aThe majority of windowing systems support the notion of a paint event, this is a special eventissued by the windowing system when the contents of a window needs to be redrawn to keepthe screen up to date. In the Embracing Windows system, we supply the following functionthat eases the task of writing code to respond to paint events:onPaint :: Window -> (Window -> Draw ()) -> GUI ()In response to a paint event, the onPaint function invokes its second argument to repaintthe necessary window. The second argument de�nes the contents of a window as a functiontaking a reference to the window itself to a value of type Draw (). This latter value de�nesthe graphical content of the window.A simple example of an application that draws a square with some text in the middle of it islisted in Figure 2.7. The mkWindow function creates a window that when closed will shut downthe application by ending the event loop, its implementation uses the createShellWindowfunction and can be seen in Appendix B.3.2. 19



main :: IO ()main = startProg appapp :: GUI ()app = do window <- mkWindow "Simple GUI"showWindow True windowonPaint window paintWinpaintWin :: Window -> Draw ()paintWin window = do drawsquaredrawText (20, 40) "Hello!"drawsquare :: Draw ()drawsquare = do moveTo (10, 10)lineTo (100, 10)lineTo (100, 100)lineTo (10, 100)lineTo (10, 10)Figure 2.7: A simple drawing application2.7 ControlsCommon user interface components such as text labels, editable text �elds, and push buttonsare built-in to most windowing systems. In the majority of the existing windowing systeminterfaces for functional languages, these built-in components are eschewed in favour of build-ing custom alternatives from scratch, instead the Embracing Windows framework providesan interface to such components. The main reason for ignoring built-in components is thatthe interface they provide is not usually orthogonal enough to integrate into a functionalGUI development system. The building of components from scratch is also seen as a testof the expressiveness of a GUI development system. From a pragmatic viewpoint this hastwo disadvantages, �rstly the components built from scratch are likely to di�er slightly fromtheir built-in counterparts and result in a non-standard look-and-feel. Secondly, the com-ponents built from scratch are likely to be less e�cient than built-in components. Built-incomponents are often referred to as controls, and are windows with particular, prede�nedbehaviour. In this report we only consider three kinds of controls, text labels, editable text�elds, and push buttons, as the main principles can be illustrated with just these controls,although Windows 95 has many others.Controls often have certain properties and behaviours in common. For example, all con-trols have some text associated with them such as the text of a button, label or edit �eld. Suchcommonalities between controls can be captured by using type classes. A general type classsupporting operations for altering and retrieving the text of a control, and also for alteringand retrieving information regarding the size of a control is de�ned as:class Control a wheresetText :: a -> String -> GUI ()getText :: a -> GUI String 20



setSize :: a -> Rect -> GUI ()getSize :: a -> GUI RectWe provide an instance of this class for each kind of control, specifying the behaviour forthe four operations as appropriate in each case. The instance declarations are shown inAppendix B.3.3.2.7.1 Text LabelsA simple example of a control is a text label. The operations de�ned in the Control class areexactly the operations we require for a text label. By de�ning a data type and appropriateinstance of the Control class, we can characterise text labels as controls:data TextLabel = ...instance Control TextLabel where...This allows us to manipulate text labels, but not to construct them. An appropriate con-struction function is required that will create an instance of the control built-in to the windowsystem and return a handle that can be used to manipulate the control. The handle can behidden from the programmer by encapsulating it inside of the TextLabel data type:mkTextLabel :: String -> Window -> Rect -> GUI TextLabelThe �rst argument speci�es the initial text of the text label, while the second and thirdarguments specify the window the text label is to be displayed in, and its position in thiswindow. By using the setText and getText methods of the Control type class, we can nowalter and retrieve the text of a text label control.The internal operation of the control construction function, and the type class operations isspeci�c to the windowing system being used. Section 2.9.2 gives details on an implementationfor the Windows 95 system.2.7.2 Edit FieldsEdit �elds can be characterised as controls in the same way as text labels. There are someextra operations that edit �elds support as well as the ones from the Control type class.Any editable control supports two operations, the �rst specifying the behaviour of the controlwhen its content has been changed, the second specifying the behaviour when the content ofthe control is committed. For an edit �eld, the content changes whenever the user edits thetext in the edit �eld. The content is considered to be committed when the user presses thereturn key. The semantics for committing the content of a control depends upon the type ofthe control. For example, a listbox may commit its current selection when the input focusis switched away from the control, but a group of radio buttons may commit whenever theselected button is changed. In a similar method to capturing the basic operations for allcontrols in the Control type class, we can capture the notion of change and commit in a typeclass: class Control a => Editable a whereonChange :: a -> GUI () -> GUI ()onCommit :: a -> GUI () -> GUI ()21



The �rst parameter to the onChange and onCommit functions determines the control to specifybehaviour for, while the second parameter speci�es the behaviour.We can now de�ne a data type for edit �elds, with suitable instances of the Control andEditable type classes, and also a construction function:data EditField = ...instance Control EditField where...instance Editable EditField where...mkEditField :: String -> Window -> Rect -> GUI EditFieldEditable controls maintain state, and common operations on this state will be to retrieveit, and to modify it. We can de�ne functions for these operations, however their types dependnot only upon the type of the control being manipulated but also upon the type of the state.To model this we would need to use a multiple parameter type class. The extended de�nitionof the Editable type class would be:class Control a => Editable a s whereonChange :: a -> GUI () -> GUI ()onCommit :: a -> GUI () -> GUI ()setState :: a -> s -> GUI ()getState :: a -> GUI sHaskell 1.3 does not support multiple parameter type classes so we must be content to im-plement the setState and getState operations on a case by case basis for each type ofcontrol.2.7.3 ButtonsMost windowing systems support a variety of buttons, such as push buttons, radio buttons,and check boxes. All of these types of button maintain a current state, which is editable bythe user interacting with the button. Buttons are editable controls and, as such, we need onlyde�ne an appropriate data type for each type of button and supply instances of the Controland Editable type classes. For a simple pushbutton that is used to acknowledge an action, asingle state button, then the onChange function can be used to specify the behaviour resultingfrom the single action of pushing the button:data PushButton = ...instance Control PushButton where...instance Editable PushButton where...mkPushButton :: Window -> String -> Rect -> GUI PushButton22



main :: IO ()main = startProg countercounter :: GUI ()counter = do window <- mkWindow "Counter"display <- mkTextLabel window "0" display_rectbutton <- mkPushButton window "Increment" button_rectonChange button (increment display button 0)showWindow True windowincrement :: TextLabel -> PushButton -> Int -> GUI ()increment display button count= let count' = count + 1in do setText display (show count')onChange button (increment display button count')display_rect = ( (0, 0), (100, 30) ) :: Rectbutton_rect = ( (0, 35), (100, 30) ) :: Rect
Figure 2.8: The counter application2.8 The Counter ProgramA common example used to illustrate how to build a simple GUI is the counter program. Thisprogram has a button labelled \Increment" and a text �eld that displays a number. Whenthe user presses the button, the value displayed in the text �eld is incremented by one. Usingthe mechanisms described in the previous sections, we can implement a counter application,using the de�nitions in Figure 2.8.The application consists of three functions:� main makes use of the startProg function to create the application's main window,graphical components and start the event loop.� counter creates the graphical components of the application: the display and the pushbutton. It also sets the behaviour of the push button when pressed to be speci�ed bythe increment function.� increment handles the event of pushing the button, it takes the current counter valueas its third argument and increments it to get the new counter value. The text of thedisplay is updated with the new value, and �nally the behaviour of the button is alteredto re
ect the new counter value. 23



The two auxiliary functions, display rect and button rect specify the position and sizeof the display and push button with respect to their containing window. The state requiredby this application, that is the value of the counter, is stored in the actual event handleritself. The ability to dynamically manipulate the event handlers specifying the application'sbehaviour is illustrated here. If we could not update the event handler determining theresponse to button presses, then we would have to store the state using a di�erent mechanism.2.9 Implementation Details2.9.1 EventsThe Embracing Windows framework interfaces to Windows 95, in which an event is de�nedas a 4-tuple, with access functions to the components of the tuple de�ned in the obviousway: type Message = Inttype Event = (Window, Message, Int, Int)getWindow :: Event -> WindowgetMessage :: Event -> MessagegetWParam :: Event -> Int -- 3rd component of tuplegetLParam :: Event -> Int -- 4th component of tupleThe �rst component of this 4-tuple is a reference to the window that the event is associatedwith, the second component speci�es the type of the event, such as a mouse click. The lasttwo components contain extra information speci�c to the type of the event.The types of events are de�ned by the EventType datatype, which has a number of dataconstructors, one for each di�erent type of event. The getEventType function converts avalue of type Event into one of type EventType by examining the second component of the4-tuple comprising the event. The details of the EventType datatype and the getEventTypefunction can be seen in Appendix B.2.3.2.9.2 ControlsA �rst attempt to provide an interface to controls might be to add a more general windowcreation primitive that takes an extra argument determining the type of the window to becreated. This could then be used as the basis of a number of di�erent functions that createspeci�c types of controls, such as a button:createButton :: Window -> String -> Rect -> IO WindowcreateButton parent title rect = mkControl "button" parent title rectThe mkControl primitive creates a new control of a speci�c type. The �rst argument deter-mines the type of the control, e.g. "button", "edit", "static", whilst the second argumentspeci�es the parent window for the control. The remaining arguments detail the text asso-ciated with the control, and its size and position. However, controls also need to be able tocommunicate events to the application. For example, when a button is pressed, the appli-cation might want to respond in a particular way. In Windows 95, a control belongs to thewindow it is displayed inside of, the parent window. Any events that the control wishes tocommunicate to the application are sent as noti�cation events to the parent of the control.24



Unfortunately, this means that a parent window must know about all of its contained con-trols so that it can respond appropriately when it receives noti�cation of an event from oneof them. It is quite common for the control itself to be able to handle the response, and thiscan be achieved by wrapping a control inside a transparent parent window that is exactlythe same size as the control. This wrapped control is the component that is used in a GUIapplication. When a control receives an event, this will be communicated to the transparentparent window which processes the event easily as it knows that it can only have come fromone control. A generic primitive for creating transparent parent windows, mkChildWindow,can be used to encode these wrapped controls within the functional language. The previousexample for creating a button control now becomes:mkPushButton :: Window -> String -> Rect -> GUI WindowmkPushButton parent text rect = do window <- mkChildWindow parent rectbutton <- createButton window text rectreturn (PushButton window button)The mkChildWindow function creates a new window that is a child of the window speci�ed byits �rst argument. The second argument determines the size of the child window. The othercontrol creation functions, mkEdit and mkLabel can be de�ned in a similar fashion, and areshown in Appendix B.3.3.
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Chapter 3WidgetsUsing the framework described in Chapter 2, we can implement an abstract interface forbuilding GUI's. This interface has similarities to both the Haggis System [6] and the Tk-Gofer System [25]. The main concept in this interface is the widget, which is a descriptionof a graphical object with a speci�c behaviour and appearance. Widgets can be composed tocreate other widgets using combinators. A library of prede�ned widgets provides support fortext labels, edit �elds and buttons.3.1 The Representation of WidgetsA widget is represented as a monadic value, thus allowing the return and >>= operations ofthe monad to be used to combine widgets. A widget is just a description of how to createa graphical component with speci�c behaviour and layout. The monad used to representwidgets is de�ned as1:newtype Widget a = Widget (Window -> GUI a)thenW :: Widget a -> (a -> Widget b) -> Widget bm `thenW` f = Widget (\window -> do let Widget m' = mr <- m' windowlet Widget n' = f rr' <- n' windowreturn r')returnW :: a -> Widget areturnW x = Widget (\window -> return x)The data constructor Widget takes a value of type Window -> GUI a as its argument, andthis value can be thought of as the widget's realization function. It takes an argumentidentifying the window in which the widget is to be realized, and creates the widget, returningan appropriate value such as a handle that can be used to further manipulate the widget. Aprogram written using widgets makes use of the function wopen which realizes a widget in atop level window. The implementation of wopen can be seen in Appendix B.4.1, and its typeis: 1The de�nition in Appendix B.4.1 also takes layout into account26



wopen :: String -> Widget a -> GUI Windowwopen creates a new top level window with a title speci�ed by its �rst parameter, and thewidget described by the second parameter is realized inside this window. A reference to thenew top level window is returned as the result of the whole action.3.2 A Library of WidgetsIn the current implementation of the Embracing Windows system, there are three prede�nedwidgets provided. Button widgets are created using buttonW, with arguments that specifythe text of the button, size of the button, and a value of type GUI () specifying the actionto be performed when the button is pressed. Similarly, edit �elds can be created using theeditW function with arguments specifying the initial text and size of the edit �eld. The valuereturned by an edit �eld can be used to retrieve the text of the edit �eld using the getTextfunction of the Control type class. Text labels can be created using the textW function witharguments specifying the text and size of the label:buttonW :: String -> Vector -> GUI () -> Widget PushButtoneditW :: String -> Vector -> Widget EditFieldtextW :: String -> Vector -> Widget TextLabel3.3 Composite WidgetsThe monadic operations return and >>= form a basis for building composite widgets. The donotation described in Section 1.2 can be used to make the syntax used in de�ning compositewidgets clearer and more concise. A composite widget that combines a label with an editabletext �eld can be de�ned as:labelledEditW :: String -> Widget EditFieldlabelledEditW label = do textW label (100, 30)editW "" (100, 30)This widget illustrates a useful abstraction, gluing a text label to an arbitrary widget. Becausewe are using a higher order functional language, it is easy to de�ne a combinator capturingthis abstraction:labelW :: String -> Widget a -> Widget alabelW label widget = do textW label (100, 30)widgetUnfortunately the size of the text label widget must be explicitly stated, and this makes theabstraction less useful. However, it is an easy extension of the layout system to incorporateautomatic sizing of library widgets, such as text labels, based on the content of the widget.If this extension is made then the labelW abstraction becomes more useful.3.4 Layout of WidgetsThe monadic widget combinators only specify the behavioural composition of widgets. Therelative layout of widgets is speci�ed separately from the behavioural composition by using27



primitives based on TEX's [12] layout mechanism. Two layout primitives are provided, hboxand vbox, with which the layout of widgets can be speci�ed (or with which other layoutcombinators can be built). When widgets are combined using do notation, one can think ofthe widgets as being piled on top of each other. The hbox layout combinator pulls these piledwidgets out to form a horizontal row of widgets, while vbox pulls the piled widgets out toform a vertical column of widgets. If no layout combinator is used then the z-order of widgetspiled on top of each other is determined by the order in which the widgets were combinedby the use of the do notation. The basic primitives for specifying layout are essentially thesame as those provided in the Haggis system. The Embracing Windows framework supportsa simple form of TEX's notion of glue, called space widgets. A space widget occupies screenspace but has no behaviour:hspace :: Int -> Widget ()vspace :: Int -> Widget ()The argument to these functions determines the amount of space that the widgets will takeup, and is speci�ed in pixels. A possible improvement would be to use a form of deviceindependent units.Using these functions, we can de�ne new layout combinators for putting margins aroundwidgets. Placing a margin to the left and right of a widget leads to an hmargin layoutcombinator:hmargin :: Int -> Widget a -> Widget ahmargin margin_width widget = hbox (do hspace margin_widthresult <- widgethspace margin_widthreturn result)Here we can see how a composite widget is built, by combining a space widget, the realwidget, and another space widget. These three widgets are layed out horizontally using thehbox layout combinator. A similar function, vmargin :: Int -> Widget a -> Widget a,lays out a widget with a margin above and below it. By combining these two layout functions,a third layout combinator, margin can be created that puts a margin all the way around awidget:margin :: Int -> Widget a -> Widget amargin width = hmargin width . vmargin widthRevisiting the labelled text widget example described in Section 3.3, we can include, in thecombinator de�nition, the use of a layout combinator to constrain the label to be placed atthe left of the widget, with a space between the label and the widget:improvedLabelW :: String -> Widget a -> Widget aimprovedLabelW label widget = hbox (do textW label (100, 30)hspace 30widget)Currently the layout system requires that the size of library widgets is speci�ed explicitlyrather than inferred in some way. For example, a text label's initial size can be determinedfrom the length of the text initially displayed. However, this was not implemented in theEmbracing Windows framework so as not to complicate the system. A disadvantage of thisis that it makes widgets less reusable, as explicit sizes have to be encoded in the de�nitions.28



3.4.1 Implementation of LayoutThe implementation of the layout of widgets involves two main steps:� Each widget has associated with it a preferred size and this information is passed tothe containing widget, which may be speci�ed by one of the layout primitives. Thecontaining widget uses this information to determine the size it would like, and thisis again passed up the hierarchy of widgets. Eventually the root widget is reached atwhich point the requested size of all widgets has been collated to form an overall requestfor the application.� The application may well have been allocated a set amount of screen space, and thismay not match the requested size of the root widget. The actual space available ispassed to the root widget, which partitions it out between its child widgets according tothe space they have each requested. This process continues, with the available size forwidgets propagating back down the widget hierarchy. Eventually, a widget that has nochildren will be reached, and this is the point at which any change in size of the widgetwill occur.This process is implemented by modifying the representation of widgets to include screen spacerequests, and also functions to realize a change in size of a widget. The widget compositioncombinators pass screen space requests up the hierarchy by combining the many requests oftheir children to form their own request. When a widget is realized in a window, then therequested size is used to set the initial size of the new window. The appropriate sizing ofwidgets is accomplished by using sizing functions belonging to each widget in the hierarchyof widgets. The widget composition combinators form their own sizing functions from logicdetermining how to split their allocated space amongst their children and the sizing functionsof the children themselves. When a widget is resized, the actual size allocated to the widgetis propagated down the widget hierarchy through the sizing functions.This mechanism is further complicated by widgets that are willing to accept changes intheir size, thus making the logic that splits up allocated space between widgets more involved.Basically, if a widget can change in size, then its size will be changed in preference to a widgetthat has asked for a �xed amount of screen space. The details of the algorithms used for layoutcan be seen in Appendix B.4.2.3.5 Stateful WidgetsWe are using widgets to model objects in a graphical user interface, and quite often suchobjects will require state. Mutable variables can be used to give widgets access to state, but,if not used carefully, widgets can become hard to reuse. A widget version of the counterapplication can be built using a mutable variable to store the current value of the counter, asshown in Figure 3.1. The mutable variable is created by the stateW function, which is a liftingof the standard newRef function into the Widget monad. stateW creates a stateful widgetthat has no on screen representation or behaviour, but when created returns a reference to apiece of mutable state. Notice that the state required by the counter is entirely encapsulatedinside of the counter widget by the use of the stateW function.A common use of the stateW function is to create a piece of state to store the contents ofa text �eld, and this can be abstracted out into a stateful text �eld:29



main :: IO ()main = startProg wwhere w = do wopen "Counter" (counter 0)return ()counter :: Int -> Widget PushButtoncounter init= vbox (do st <- stateW initdisplay <- textW (show init) display_sizebuttonW "Increment" button_size (handler display st))handler :: TextLabel -> Ref Int -> GUI ()handler display st = do count <- getRef stlet count' = count + 1setRef st count'setText display (show count')display_size = (100, 30) :: Sizebutton_size = (100, 30) :: SizeFigure 3.1: A Widgets counterstateTextW :: Show a => Size -> a ->Widget (TextLabel, ((a -> a) -> GUI ()))stateTextW size init= do st <- stateW initlabel <- textW (show init) sizelet update f = do v <- getRef stlet v' = f vsetRef st v'setText label (show v')return (label, update)The stateTextW function returns an action whose result is a pair of values, the �rst of whichcan be used in operations on the label, while the second is a function that can be used to alterthe state of the label. The stateful text �eld can be reused easily, and the improved counterprogram is listed in Figure 3.2.The main advantage of this program over the one in Section 2.8 is compositionality. Itallows the counter application to be constructed as a single widget that could easily be usedin other applications by using the widget combinators >>= and return. Also the automaticlayout support simpli�es the physical description of the GUI, with only the width and heightof widgets needing to be speci�ed.3.6 Comparison to HaggisThe syntax for writing Widget programs is very similar to that used by Haggis but, unlikeHaggis, the Widget system does not make any use of concurrency. To illustrate the di�er-ence that concurrency makes to specifying GUIs, we present a Haggis counter application30



main :: IO ()main = startProg wwhere w = do wopen "Counter" (counter 0)return ()counter :: Int -> Widget PushButtoncounter init= vbox (do (display, update) <- stateTextW display_size 0buttonW "Increment" button_size (update (+1)))display_size = (100, 30) :: Sizebutton_size = (100, 30) :: SizeFigure 3.2: An Improved Widgets countermain :: IO ()main = do env <- mkDC ["*title:Counter"](lbl, lbl_dh) <- label "0" env(btn, button_dh) <- button (text "Increment") (+1) envforkIO (handler 0 btn lbl)realiseDH env (vbox [lbl_dh, button_dh])handler :: Int -> Button (Int -> Int) -> Label -> IO ()handler n btn lbl = do f <- getButtonClick btnlet n' = f nin setLabel lbl (show n')handler n' btn lblFigure 3.3: A Haggis counter(Figure 3.3) and contrast it with the Widget version.We will not explain all of the functions used in the Haggis counter application, but referthe interested reader to the documentation included in the Haggis system [5]. The Widgetand Haggis counters both consist of a combination of a text �eld and a button. The Haggiscounter does not specify the behaviour of the button using a function that is called in responseto user input. Instead, a separate thread of control is started using the forkIO function. Thisseparate thread waits for the button to be pressed and then applies the integer modifyingfunction emitted by the button to the current value of the counter. The text label is alteredto show this new value, and �nally we return to the beginning of the handler function to waitagain for another button press. The handler function for Haggis is similar to the handlerfunction for Widgets, except that, in the widget program, we don't need to explicitly waitfor a button press. Instead, in the widget program we specify the behaviour required when abutton press event occurs by the use of a function from the type of an event to the type ofan I/O action (in this case the type is GUI ()). Similarly, when we have processed a buttonpress, instead of direct recursion we return to the event loop to await the next event.31



The addition of concurrency in the Haggis program frees the programmer from having todeal with the event loop. However, in our example, we have written a mini event loop thatpolls for button presses. In general, the Haggis programmer may end up writing a number ofsmaller more speci�c event loops. An application whose responses to events changes as theprogram executes will be better suited to the Haggis system. For example, an applicationthat has two buttons which, when pressed in a particular sequence, quit the program, requiresthe code describing the behaviour of the application to be split up into two handlers:main :: IO ()main = startProg wwhere w = do wopen "Test" testWreturn ()testW :: Widget PushButtontestW = vbox (do one <- buttonW "One" button_size (return ())buttonW "Two" button_size (onChange one quitapp)button_size = (100, 30) :: SizeInitially, pressing the �rst button has no e�ect, however, pressing the second button changesthe behaviour of the �rst button such that when it is pressed the application will be shutdown.In the Haggis system, we do not need to split up the description of the application'sbehaviour, instead it can be described as one piece of code:main :: IO ()main = do env <- mkDC ["*title:Test"](one, one_dh) <- button (text "One") () env(two, two_dh) <- button (text "Two") () envforkIO (handler one two lbl)realiseDH env (vbox [one_dh, two_dh])handler :: Button () -> Button () -> IO ()handler one two = do getButtonClick twogetButtonClick oneshutdownShopThe handler function waits until the button labelled \Two" is pressed, and then continues bywaiting until the button labelled \One" is pressed. Once this has happened, the applicationis shut down. If we had a large number of buttons that had to be pressed in a particularsequence then it would be cumbersome to express this in the Widget system, however it wouldbe relatively easy to express in the Haggis system.If the behaviour for each of the buttons is independent then the program written inthe Widget system would be very similar to the program written in the Haggis system.Both programs would create two buttons, and have two separate functions specifying thebehaviour of the buttons independently. In the Haggis version, two threads of control wouldbe concurrently forked that wait for button presses and perform the appropriate behaviour,whilst in the Widget version, two handler functions specify the behaviour of the buttons andare called in response to user input. 32



Chapter 4Fudgets4.1 Overview of FudgetsThe Fudgets system [9] is a well established toolkit for building GUI applications in thefunctional language Haskell. It uses an abstraction, the fudget, to describe a self containedGUI component.A fudget is built on top of the concept of a stream processor. A stream processor is aprocess with one input stream and one output stream. The type of a stream processor thatinputs values of type a and outputs values of type b is written as SP a b. Stream processorsare built from three basic stream processors using a continuation passing style. The basicstream processors are:getSP :: (a -> SP a b) -> SP a bputSP :: a -> SP b a -> SP b anullSP :: SP a bThe getSP stream processor retrieves a value from the input stream and processes it usingthe �rst argument to getSP, transforming itself into a new stream processor. Similarly, putSPoutputs the value indicated by its �rst argument on the output stream and turns into thestream processor speci�ed by its second argument. The nullSP stream processor terminatesimmediately ignoring any values on its input stream and producing no values on its outputstream.A simple example of a stream processor is the mapAccumlSP function, which creates astream processor with an internal state. The �rst parameter to this function speci�es a statemodifying function, that changes the state given the value on the stream processor's inputstream. This state modifying function also generates the values emitted on the output stream.This stream processor can be written in terms of the basic stream processors as:mapAccumlSP :: (s -> b -> (s, c)) -> s -> SP b cmapAccumlSP f state = getSP $ \input ->let (state', output) = f state inputin putSP output (mapAccumlSP f state')A fudget is just a stream processor that can communicate with the windowing system.Fudgets can be combined using combinators that specify how the single input and outputstreams of fudgets are connected together. These combinators are, >==<, >*< and >+< whichcompose fudgets in series, and in parallel (either untagged or tagged), respectively. Thebehaviour of these combinators is de�ned as follows:33



� >==<, composes two fudgets serially with the output from the �rst fudget sent to theinput of the second:>==< :: F a b -> F c a -> F c b
f2f1

f1 >==< f2� >*<, composes two fudgets in parallel. The input values are routed to both fudgets, andthe output values are merged to form the output stream:>*< :: F a b -> F a b -> F a b
f2

f1

values

untaggeduntagged

values

f1 >*< f2� >+<, composes two fudgets in parallel. The input values are expected to be taggedindicating to which fudget the value is to be routed. Similarly, the output values aretagged indicating which fudget they came from:>+< :: F a b -> F c d -> F (Either a c) (Either b d)
f2

f1

values

taggedtagged

values

f1 >+< f2The counter example can be expressed with fudgets using the code in Figure 4.1, which isa simpler version of the SmallCounter.hs example from the original fudgets distribution [3].The fudlogue function takes the main application fudget as its argument and turns it intothe appropriate type for the Haskell I/O system. A fudget is realized in a top level or shellwindow using the shellF function. This function takes two arguments, the �rst is a stringspecifying the title for the shell window, and the second is the fudget to be realized inside theshell window. In this example, the counterF fudget combines three separate fudgets usingthe series combinator, m >==< n. The intDispF fudget creates an integer display, while the34



main :: IO ()main = fudlogue (shellF "Counter" counterF)counterF :: F a ClickcounterF = intDispF >==<absF countSP >==<buttonF "Increment"countSP :: SP click IntcountSP = mapAccumlSP inc 0where inc n _ = (n + 1, n + 1)Figure 4.1: A Fudget counterbuttonF fudget creates a labelled button. The fudget connecting the button to the integerdisplay is an abstract fudget; it has no input or output to the window system, and onlycommunicates with the outside world through the fudgets it is linked to. Abstract fudgetsare speci�ed using stream processors, with the absF function converting a stream processorinto a fudget:absF :: SP a b -> F a bA fudget is a stream processor that can also communicate with the windowing system, andso the absF function merely turns a stream processor into a fudget that acts like the streamprocessor but does not communicate with the windowing system.4.2 Implementation of FudgetsThe original implementation of the Fudget system used stream processors as the basic build-ing blocks for describing process networks, extending them with connections to the windowsystem to create fudgets. This method could be adopted to encode the Fudget system in theEmbracing Windows framework. However, it does not lend itself well to encapsulating exist-ing GUI components such as the controls in Windows 95 as fudgets. An alternative approachbased on work by Reid and Singh[21], uses a functional representation for fudgets:type Handler a = a -> GUI ()type Fudget a b = Window -> Handler b -> GUI (Handler a)Here, a fudget is modelled as a function returning a realization action that will create theappropriate GUI component. The function requires the window in which the fudget is to berealized as its �rst argument, whilst the second argument is an output handler, which willbe used to send output to another fudget. The return value is of type GUI (Handler a)indicating that the realization action may perform I/O, and returns an input handler thatcan be used to send input to this fudget. 35



Using this encoding, it is possible to create atomic fudgets for buttons, edit �elds, andtext labels. For example, a button fudget is created by using the buttonF function,buttonF :: String -> Size -> F Click ClickbuttonF text (w, h) parent outputHandler= do button <- mkPushButton parent text ((0, 0), (w, h))onChange button (outputHandler Click)return inputHandlerwhere inputHandler a = outputHandler ClickThe mkPushButton control construction function is used to create the window's push buttoncontrol. The onChange function is used to set the behaviour of the button when it is pressed.In this case when the button is pressed the value Click is emitted on the output stream of thefudget. Finally the input handler returned simulates the button being pressed by emittingthe value Click on the output stream of the fudget.The fudget combinators simply map onto functions that plumb together the input andoutput handler functions of fudgets. For example, the de�nition of the >==< combinatorfollows directly from the representation we are using for fudgets, connecting together theinput handler of the second fudget to the output handler of the �rst fudget:(f1 >==< f2) parent outputHandler= do handler <- f1 parent outputHandlerinputHandler <- f2 parent handlerreturn inputHandlerThe other combinators, >*< and >+< are expressed similarly and can be seen in detail inAppendix B.5.7.Stream processors are simply fudgets that do not communicate with the windowing sys-tem. The representation used for fudgets can be reused for stream processors by using a typesynonym:type SP a b = F a bThe basic stream processors can easily be encoded using the functional representation usedfor fudgets, for example, we can code the getSP stream processor as:getSP :: (a -> SP a b) -> SP a bgetSP f parent outputhandler= let inputhandler a = do f a parent outputhandlerreturn ()in return inputhandlerThe getSP stream processor does not create any windows but simply returns an input handler.This handler invokes the continuation specifying the behaviour of the stream processor beingcreated given the value read from the input stream.4.3 Layout of FudgetsThe fudget combinators, >==<, >*<, and >+<, can be used to link together fudgets be-haviourally. However, they do not specify any details about the layout of the fudgets beingcombined. The original implementation of the Fudgets system provided support for threeways to layout fudgets: 36



� Placer Layout: This method uses functions that modify the layout of a single fudget.Because fudgets can be combined using the fudget combinators, this may alter thelayout of many fudgets.� Combinator Layout: This method uses variants of the fudget combinators to specifythe layout of a fudget program. The 
exibility in the layouts possible is constrained bythe 
ow of data in the fudget program because layout is based on fudget combinatorsthat control the 
ow of data.� Name Layout: This method speci�es the layout of fudgets independently from thespeci�cation of the 
ow of data between fudgets. Fudgets are named, and the layoutspeci�ed in terms of these names, resulting in a more 
exible mechanism than combi-nator layout.In the Embracing Windows framework, only the �rst and second of these methods for layouthas been implemented. In the original Fudgets system, combinator layout is implemented interms of placer layout, and this approach is taken in the Embracing Windows framework.All of the above methods for specifying the layout of a fudget program do so in a hi-erarchical fashion, with each fudget residing in a box. These boxes can be placed togetherusing placers. As in the Widgets system, placers are based upon the box mechanisms of TEX.Examples of some placers are:horizontalP :: PlacerverticalP :: PlacerThe horizontalP placer lays out a group of fudgets next to each other horizontally, whilethe verticalP placer lays out fudgets vertically. Using a placer, the layout of certain fudgetscan be speci�ed by using the placerF function:placerF :: Placer -> F a b -> F a bThis function applies the placer to all of the fudgets composing the single fudget speci�ed bythe second argument. Revisiting the counter example, we can layout the fudgets verticallyby using placerF:improvedcounterF :: F a ClickimprovedcounterF = placerF verticalP counterFSome useful layout functions de�ned in terms of the placerF function are:hBoxF :: F a b -> F a bhBoxF = placerF horizontalPvBoxF :: F a b -> F a bvBoxF = placerF verticalPThe fudget combinators for layout take a tuple describing a fudget and a layout orientationas their �rst argument, followed by another fudget as their second argument. The two fudgetsare combined using the normal fudget combinators, but are also placed relative to each otheraccording to the orientation speci�ed. 37



main :: IO ()main = fudlogue (shellF "Counter" counterF)counterF :: F a ClickcounterF = (intDispF display_size, Above) >==#<(absF countSP >==< buttonF "Increment" button_size)countSP :: SP click IntcountSP = mapAccumlSP inc 0where inc n _ = (n + 1, n + 1)display_size = (100, 30) :: Sizebutton_size = (100, 30) :: Size
Figure 4.2: A Fudget counter with layoutdata Orientation = Above | Below | RightOf | LeftOf>#==< :: (F a b, Orientation) -> F b c -> F a c>#*< :: (F a b, Orientation) -> F c d -> F (Either a c) (Either b d)>#+< :: (F a b, Orientation) -> F a b -> F a bThe counter example can now be written using these combinators as can be seen in Figure 4.2.The implementation of layout for fudgets follows the same process as for Widgets, withrequests for screen space propagating up through a hierarchy of fudgets, and the actualallocated space propagating down the hierarchy through functions that resize fudgets.Similarly to the widget system, explicit sizes are required for the library fudgets suchas push buttons, editable text �elds, and text labels. In the original fudgets system libraryfudgets size themselves according to the content of the fudget. For the same reason as inthe widget system we have not implemented this ability to automatically size library fudgetsdepending upon their content.4.4 Looping CombinatorsA number of combinators from the original implementation of the fudgets system have beenleft out from the implementation using the Embracing Windows framework. Some of thesecombinators cannot be encoded due to the choice of representation for fudgets. In particularthe representation does not preserve the correct order of input values arriving at a fudget.38



This implies that certain recursive combinators cannot be supported. For example, considerthe loopF combinator, which connects the output of a fudget back to its own input, creatinga feedback loop:loopF :: Fudget a a -> Fudget a a
f1

loopF f1The output from the fudget provided as an argument to this combinator forms the output ofthe composed fudget, but is also sent back to the fudget's input. Using a �xpoint combinator,we can attempt to implement such a looping combinator as:loopF :: F a a -> F a aloopF f parent outputHandler= let inputhandler = fix (\handler ->f parent (\x -> do outputHandler xhandler x))in return inputhandlerHere the fix function is a �xpoint combinator lifted into the GUI monad. The primitive�xpoint combinator is implemented in the IO monad, and the WindowSystem type class canbe used to lift the primitive into di�erent monads. The type of the �xpoint combinator for amonad m, is:fix :: (a -> m a) -> m aThis primitive allows us to use the input handler returned by the fudget we are actuallyconstructing, and hence we can route a value back to the input of the fudget that producedthe value.However, this does not work as we might hope; when a value is produced as outputfrom a fudget composed using the loopF combinator it is immediately piped around to thefudget's input and processed, potentially before any values that have already been sent to thefudget on its input stream. Input values are thus processed out of order, unlike the originalFudgets system. This problem is important as most reasonable applications will require ause of such looping combinators at some point. Purpose built combinators could be used toensure a particular order of processing of input values, or alternatively we could revert tousing a representation of fudgets based on stream processors as in the original Fudget systemimplementation.Because stream processors are implemented as fudgets that do not make use of the window-ing system, they also su�er from these problems. In particular the mapAccumlSP function usedin the counter example for maintaining state cannot be written using the basic stream proces-sors, and is instead implemented using mutable state. The problem is that the mapAccumlSPfunction maintains state by using a feedback loop to feed the latest version of the state backinto itself. Using mutable state, this function can be written as:39



mapAccumlSP :: (a -> b -> (a, c)) -> a -> SP b cmapAccumlSP f init parent outputhandler= do state <- newRef initreturn (inputhandler state)where inputhandler state a = do s <- getRef statelet (s', b) = f s asetRef state s'outputhandler bThis stream processor creates a mutable variable to store the internal state in, and returnsan input handler. This handler is invoked when a value is read from the input stream. Thestate is extracted from the mutable variable and modi�ed according to the function speci�edas the �rst argument to the mapAccumlSP function. The new state is stored in the mutablevariable, and a value emitted on the output stream.
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Chapter 5The Essence of Functional GUI'sIn this Section, we present an essence of the two high-level systems developed in Chapters 3and 4. A mapping between components of the two systems is described which can allow amixture of the two systems within individual applications.The essence of the Fudgets system can be seen in Figure 5.1, and the essence of theWidgets system in Figure 5.2. These two systems are similar, in that they both have:� A datatype representing graphical components.� A number of atomic graphical components.� Combinators for building complex graphical components from the atomic ones.The major di�erence between the two systems is in the combinators used to build compositegraphical components. In the fudget system, the combinators specify the relationships be-tween the input and ouput values produced by the components when the GUI is used. Inthe widget system, the combinators are the monadic operations returnW and thenW. Theatomic components return values that can be used to manipulate the component, and areoften referred to as handles. A dependency between components involves binding a nameto the handle associated with one of the components and then making use of this in thespeci�cation of the related component. Since both systems use the combinators to expressrelationships between graphical components, it is not surprising that we can de�ne a mappingbetween the two systems, albeit a restricted one. This mapping allows graphical componentsdata Fudget a b = ...buttonF :: String -> F Click ClickintDispF :: F Int alabelF :: String -> F String a(>==<) :: F a b -> F b c -> F a c(>*<) :: F a b -> F a b -> F a b(>+<) :: F a b -> F c d -> F (Either a c) (Either b d)Figure 5.1: The essence of Fudgets41



data Widget a = ...buttonW :: String -> Size -> GUI () -> Widget PushButtoneditW :: String -> Size -> Widget EditFieldtextW :: String -> Size -> Widget TextLabelthenW :: Widget a -> (a -> Widget b) -> Widget breturnW :: a -> Widget a Figure 5.2: The essence of Widgetsfrom one system to be used in a limited way in the other system. The restricted fudget towidget mapping is accomplished by the fudgetToWidget function:fudgetToWidget :: F a b -> Widget ()fudgetToWidget f = Widget (\window -> do f window nullHandlerreturn ())nullHandler :: Handler ()nullHandler _ = return ()The nullHandler function is a simple output handler that is used to process any outputproduced by the fudget. The input handler that the fudget returns as a result of its realizationis ignored. This limits the usefulness of the mapping because the wrapped fudget cannotinteract with other widgets. The mapping could be used in an accounting application thatprovides an option to start a calculator in a separate window for independant calculuations.If a fudget version of a calculator is available then the rest of the accounting applicationcould be written using the Widgets system with the option for displaying the calculator usingthe fudget version of the calculator under the above mapping. Since there is no interactionbetween the calculator and the accounting application the above mapping su�ces. In generalit would be useful to have a stronger mapping that allowed the fudget to interact with otherwidgets.Using a similar method, we can de�ne a function that converts a widget to a fudget. Thismapping su�ers from the same restrictions as the mapping from a fudget to a widget:widgetToFudget :: Widget a -> F b cwidgetToFudget (Widget w) parent outputhandler= do w parentreturn nullHandlerThe fudget takes the widget as its �rst argument, with the second and third argumentsspecifying the window the fudget will be realized in, and the output handler the fudget canuse to send values on its output stream. The fudget is created by using the widget's realizationfunction. The return value of the widget realization function is ignored, and the nullHandlerfunction is used for the fudgets input handler. The wrapped widget cannot send output onthe fudgets output stream, or read from the fudgets input stream, and so cannot interactwith other fudgets. 42



Chapter 6Conclusions and Future WorkThere are a number of existing systems for the development of GUIs in a non-strict functionallanguage, such as Fudgets, Gadgets and Haggis. However, the lower level components of thesesystems all solve very similar problems, such as how to handle I/O in functional languages, andalso how to provide a structured interface to the event-driven model of windowing systems.Noble and Runciman [15] compare and contrast two systems for developing GUI's in functionallanguages. However, these systems are seperate standalone entities. A number of low levelinterfaces for windowing systems have recently been developed, such as Finne's X-Librarybindings [6] which are part of the Haggis system. Reid [20] has also developed an interface forboth the X-windows system and the Windows 95/NT systems as an extension to the Hugsfunctional programming system. This system has been used as the basis for an active virtualreality markup language (active VRML) implementation, making use of a graphics library[7], and a cooperative version of Concurrent Haskell [8].We have presented the details of a system for the construction and comparison of graphicaluser interfaces in a purely functional language. The system is intended as a framework for theresearch and development of high-level abstractions for constructing graphical user interfaces.Illustrating this we have described two high-level abstractions that are built on the framework.The �rst of these abstractions, Widgets, uses a number of ideas from the Haggis and TK-Gofer systems, but does not make use of concurrency as Haggis does. The second, Fudgets, isimplemented using an alternative representation to the original stream processing model usedby Hallgren and Carlsson. The alternative representation is not however expressive enoughto model the looping combinators of the original Fudgets system. This is a result that hasnot previously been noted.The Widget and Fudget systems di�er in the approach they take to structuring the GUIcomponent of an application at a high-level. In particular, they di�er in the data structureso�ered to the programmer for representing GUI components and also the way in which thesecomponents can be combined and physically laid out on the display screen. The EmbracingWindows framework provides a basis for building and comparing systems such as the Widgetand Fudget systems.One avenue of research that could be particularly interesting is to try and use the frame-work to explore relationships between high-level abstractions like Fudgets and Widgets, suchas their relative expressive power. Chapter 5 presented a restricted mapping between the twosystems. Preliminary work has already revealed that this mapping can be strengthed to acomplete mapping from fudgets to widgets. The formalization of the relationships betweensystems such as Fudgets and Widgets may bene�t from a layered approach; by specifying43



a formal semantics for the Embracing Windows system, the semantics of these high-levelsystems could be simpli�ed.There are also a number of other high-level abstractions for creating GUIs in functionallanguages that could be implemented using this framework, such as one based on the Con-current Clean I/O system. The Clean language uses a type system incorporating uniquenesstypes [22]. A type can be annotated to be unique, indicating that a value of this type must notbe shared at the point in an evaluation where the value is required. It is interesting to notethat the monadic style of I/O can be encoded using uniqueness types. The paradigm usedby the Clean system for constructing graphical interactive programs does not inherently relyupon the uniqueness type system for performing I/O operations. As such, the paradigm couldbe implemented using a di�erent low level I/O mechanism such as monadic I/O. We haveperformed some preliminary work attempting to construct a system based on the Embrac-ing Windows framework that uses the Clean paradigm for constructing graphical interactiveprograms. The results of this work indicate that there are no inherent di�culties in buildingsuch a system.Currently, the Widgets and Fudgets systems both support a form of automatic layout toaid the GUI programmer. The layout system is very similar in both of these systems. A logicalstep would be to try and abstract the layout system away from the details of the particularsystems. Pragmatically, the layout of graphical components is often performed using a GUI-builder. GUI-builders make use of direct manipulation to allow the user to literally drawthe interface they want. Such graphical tools are important in the development of graphicalinteractive applications. However GUI-builders cannot cope with all possible layouts, andhave great di�culty with layouts that can change dynamically. Having a programmaticmechanism for specifying the layout of components is therefore still important. In generalwe would expect most application interfaces to be handled by a GUI-builder, and only rarelywould the full expressiveness of the programmatic mechanism be required. The output ofsuch GUI-builders is often in terms of the programmatic mechanism.When developing graphical applications the development environment can play a signi�-cant role in making the process quick and easy. A GUI-builder is just one example of a toolthat would form part of a development enviornment for graphical applications. Abandoningthe concept of 
at text �les for specifying the entire code of a graphical application can leadto a development environment where the programmer literally draws the required interface,and then proceeds to write small blocks of code attaching them to the components of theinterface. A good example of this concept in action is seen in the Visual Basic1 programmingsystem, where programs are built by drawing forms and then writing a number of small blocksof code. A speci�c block of code describes the behaviour of a speci�c component on a form.However, Visual Basic is based on an imperative language and whether the approach willwork well for declarative languages is a topic for further research.The Embracing Windows framework has bene�ted from being implemented in an in-terpreter. Since design of graphical interfaces is very much an evolutionary process, it isadvantageous to have a quick turn around from modifying the code specifying the interfaceto seeing the interface realized on a computer screen. Once the interface has been evolvedhowever, then a compiler is a better choice of tool to give an e�cient application.Finally, in order to shoehorn systems such as Haggis, and Gadget Gofer into the EmbracingWindows framework it appears that a form of concurrency will be necessary. This could beadded into the framework as a new layer that provides minimal support for concurrency upon1Visual Basic is a registered trademark of the Microsoft Corporation44



Figure 6.1: A Potpourri of graphical applicationswhich the particular communication protocols could be built. The form of concurrency thatbest suits graphical user interfaces is still an open question.A selection of graphical applications that have been written using the Embracing Windowsframework can be seen in Figure 6.1.6.1 AcknowledgementsI would like to especially thank Mark P. Jones for his many valuable comments, suggestionsand careful reviews of draft versions of this report. Also thanks to Graham Hutton andBenedict R. Gaster for numerous useful discussions and comments which, I hope, have enabledme to improve the content and presentation of this work. Also thanks to Rob Noble for someinsightful comments regarding the calculator example presented in the appendices. This workwas carried out while the author was a member of the Functional Programming Group at theUniversity of Nottingham, UK, with �nancial support from the University of Nottingham.45



Appendix AExample ApplicationsThis appendix presents various applications that have been written in both the Widgets andFudgets systems. The main goal when developing these applications was their reusability.This is illustrated particularly well with the combination lock example in Appendix A.2,which reuses the entire numeric keypad developed for the calculator in Appendix A.1.A.1 A CalculatorA common test of GUI development systems is to write an application modelling a simpledesk calculator. The application should present an interface to the user very similar to thatof a real calculator, with a display screen and a number of buttons for entry of numbers, andbasic operations. The widget version of the calculator is shown in Figure A.1.A.1.1 The Calculator State MachineBefore describing the implementation of the GUI for the calculator, we present the underlyingmodel of the calculator itself. This model corresponds to the application part of the calculatorprogram, as opposed to the GUI part.The behaviour of the calculator can be described by a simple �nite state machine. Theinput to the calculator is just a character corresponding to the key pressed by the user. The
Figure A.1: A Widget calculator46



output of the calculator is modelled as a pair of values, the �rst of which corresponds to thevalue on the calculator's display. The second value of this pair is a function, modelling allthe calculations since the equal key was last pressed. A simple �nite state machine such asthis can be easily implemented in a functional language:type CalcState = (Int, Int -> Int)eval :: Char -> CalcState -> CalcStateeval c state | isDigit c = evalDigit (ord c - ord '0') state| otherwise = evalOperation c stateevalDigit :: Int -> CalcState -> CalcStateevalDigit n (d, a) = (10 * d + n, a)evalOperation :: Char -> CalcState -> CalcStateevalOperation 'C' (d, a) = (0, id)evalOperation '=' (d, a) = (a d, const (a d))evalOperation op (d, a) = (0, evalOperator op (a d))evalOperator :: Char -> (Int -> Int -> Int)evalOperator '+' = (+)evalOperator '-' = (-)evalOperator '*' = (*)evalOperator '/' = (div)The eval function describes the semantics of pressing a key on the calculator's keypad. Ifthe clear, \C", key is pressed then the display is zeroed, and the accumulating function is setto the identity function. If the equal key is pressed, then the display is updated by applyingthe accumulating function to the current display value. The accumulating function becomesa constant function returning this same value. When a number key is pressed then the valuebeing displayed is updated, multiplying it by ten and adding the number corresponding tothe key pressed. The accumulating function does not change in this case. The only remainingkeys correspond to the arithmetic operators, and pressing one of these sets the display tozero, and partially applies the appropriate arithmetic operator to the result of applying theaccumulating function to the current display value.A driver program is required to make the calculator useful, for instance a simple textbased calculator can be implemented as:main :: IO ()main = calc (0, id)calc :: (Int, Int -> Int) -> IO ()calc (d, a) = do putStr ("\nDisplay: " ++ show d ++ "\n")c <- getCharcalc (eval c (d, a))The semantics described in this section associates the same precedence level to all oper-ators. However, experimenting with real desktop calculators results in a suprising array ofdi�ering behaviours regarding precedence of arithmetic operators. The problem of having the47



same precedence level for all operators is not solved here as we are mainly concerned withthe interface for the calculator rather than the semantics of the calculator.A.1.2 A Widget Graphical User InterfaceThe GUI of the calculator is modelled as a widget that appears in a top level window.However, note that because the entire calculator is encapsulated as a Widget, it does nothave to be used in a top level window, but could be used to build more complicated Widgets.For example, a simple application that composes a number of calculators next to each otherin a line can be easily written using the hbox combinator:main :: IO ()main = startProg wwhere w = do wopen "Multiple Calculators" multicalcWreturn ()multicalcW :: Widget ()multicalcW = hBox (do calcWcalcWcalcW)The calcW function is the calculator widget that we describe in the remainder of this section.The calculator maintains some state storing the current value of the display, and anaccumulator function, indicating the calculation entered so far. This is just the state asdescribed in Appendix A.1.1:type CalcStVar = Ref CalcStateThe basic calculator widget creates an initial value of the state, and the widgets for the displayand calculator keypad. These widgets are composed vertically, so that the display appearsabove the keypad. The state and a handle for the display are passed to the keypad widget sothat the state can be modi�ed and the display updated when keys are pressed:calcW :: Widget ()calcW = vbox (do st <- stateW (0, id)display <- dispWkeysW st display)The display is implemented using the standard textW widget. However, a thin margin iswrapped around this widget to make the visual appearance better.dispW :: Widget TextLabeldispW = margin 1 (textW "0" display_size)display_size = (100, 30) :: SizeA generic keypad widget is constructed using the matrix layout combinator which takes awidth of the matrix, and a list of widgets to be formed into a matrix shape. The widgets areused to build up the lines of the matrix, so that each line has at most the speci�ed number ofwidgets on it. The keypadW function creates a keypad widget given a list of pairs. The pairsde�ne the text label and behaviour of each key in the keypad:48



keypadW :: Int -> [(String, GUI ())] -> Widget ()keypadW width keys = do matrix width (map key keys)return ()The keys themselves are generated using the key function, which adds a thin margin aroundthe buttons for a better visual appearance:key :: (String, GUI ()) -> Widget PushButtonkey (label, action) = margin 1 (buttonW label button_size action)button_size = (30, 30) :: SizeThe keypad of the calculator consists of two separate keypads, one for the number keys,and one for the operation keys. A generic number keypad is implemented in terms of thekeypadW widget. The numberPadW function takes a function as its argument that describesthe behaviour of the keypad. This function expects an integer value corresponding to a keythat has been pressed on the keypad as its �rst argument:numberPadW :: (Int -> GUI ()) -> Widget ()numberPadW f = keypadW 3 (map formkey [9,8..0])where formkey n = (show n, f n)The number keypad for the calculator is implemented in terms of the generic numberPadWcombinator. The function specifying the behaviour of the keys in the keypad uses the functionkeyOp to modify the state of the calculator and update the display. The state modifyingfunction used in this case is the evalDigit function determining the semantics of enteringdigits into the calculator.numbersW :: CalcStVar -> TextLabel -> Widget ()numbersW st disp = numberPadW (\n -> keyOp st disp (evalDigit n))keyOp :: CalcStVar -> TextLabel -> (CalcState -> CalcState) -> GUI ()keyOp st disp f = do (d, a) <- getRef stlet (d', a') = f (d, a)setRef st (d', a')setText disp (show d')The keypad for the operations uses the keyPadW combinator and the keyOp function in asimilar way to the numbersW function. In this case however, the state modifying function isevalOperation, determining the semantics of entering an operation into the calculator.operationsW :: CalcStVar -> TextLabel -> Widget ()operationsW st disp = keypadW 2 [([op], keyOp st disp (evalOperation op))| op <- "+-*/=C"]Both of the keypads are combined to form the single keypad used in the calculator. Thekeypads are placed next to each other horizontally using the hbox layout combinator:keysW :: CalcStVar -> TextLabel -> Widget ()keysW st disp = hbox (do numbersW st dispoperationsW st disp)49



Finally, the driver program for the calculator realizes the calculator widget in a top levelwindow:main :: IO ()main = startProg w wherew = do wopen "Calculator" calcWreturn ()A.1.3 A Fudget Graphical User InterfaceThe fudgets calculator is similar to the widgets version, and starts by realizing the calculatorfudget in a top level window. Again the entire calculator is encapsulated as a single fudget,and so may be used to build more complicated fudgets:main :: IO ()main = fudlogue (shellF "Calculator" calcF)The state is the same as for the Widget calculator, consisting of the current value on thedisplay of the calculator, and an accumulator storing the current computation in progress.Ideally, we would like to use a recursive stream processor to model the state, but due to theproblem described in Section 4.4 this will not work. Instead we use mutable state indirectlyby using the mapAccumlSP function.The main calculator consists of four components, a display screen fudget, two abstractfudgets, and a fudget representing the keypad of the calculator. The two abstract fudgetsencapsulate the logic of the calculator, while the remaining fudgets describe its user interface.These four fudgets are combined together serially, and the physical layout of the fudgets isspeci�ed using the vBoxF layout function:calcF :: F Click acalcF = vBoxF (displayF >==<absF displayState >==<absF (stateSP (0, id)) >==<keysF)The display screen is based on the standard integer display fudget, intDispF, but is wrappedby the marginF fudget combinator that adds a margin around the top, bottom, left andright of a fudget. The �rst parameter to the marginF combinator indicates the size of thismargin.displayF :: F Int adisplayF = marginF 1 (intDispF display_size)display_size = (80, 30) :: SizeThe current value to be displayed on the calculator's screen must be extracted from the stateof the calculator, and this is the job of the displayState abstract fudget. It is a streamprocessor that reads in a value indicating the current state of the calculator, and discards theaccumulator component, writing the current display value to its output stream.displayState :: SP CalcState IntdisplayState = getSP (\(d, a) -> putSP d displayState)50



In the same manner that we abstracted the notions of a generic keypad, and of a numerickeypad from the widget version of the calculator application we do the same for the fudgetversion.Starting with the generic notion of a keypad, we build a fudget that uses the matrixFlayout combinator to build a keypad. The keypadF function takes the width of the keypadand a list specifying the details of the keys. Each key is determined by its label and a valuethat is emitted from the keypad when it is pressed. Just as we added a thin margin to thekeys in the keypad for the widget version we do the same here. An abstract fudget is usedto produce the required value when a particular button representing a key in the keypad ispressed:keypadF :: Int -> [(String, a)] -> F Click akeypadF width keys = matrixF width (>*<) (map key keys)key :: (String, a) -> F Click akey (label, action) = const action >^=< marginF 1 (buttonF label button_size)button_size = (30, 30) :: SizeA numeric keypad fudget, numberPadF, can be built using the generic keypad combinatorkeypadF in a similar way to the numberPadW widget. Instead of taking a function describingthe action to be performed when one of the digits on the numeric pad is pressed, the numberpressed is emitted on the output stream of the fudget:numberPadF :: F Click IntnumberPadF = keypadF 3 (map formkey [9,8..0])where formkey n = (show n, n)The calculator's keypad is composed of two separate components, the �rst is a numerickeypad, whilst the second is a keypad whose keys correspond to the available arithmetic oper-ations. The numeric keypad is de�ned as a specialised version of the more generic numberPadFfudget, by simply processing the ouput digit with the appropriate function of the state ma-chine. The arithmetic operation keypad is built using the keypadF fudget by specifying theoutput values for the keys to be the application of the evalOperation function from the statemachine to the character representing the particular operation:numbersF :: F Click (CalcState -> CalcState)numbersF = absF (mapSP evalDigit) >==< numberPadFoperationsF :: F Click (CalcState -> CalcState)operationsF = keypadF 2 [([op], evalOperation op) | op <- "+-*/=C"]The entire calculator keypad is formed by combining the specialised numeric keypad andthe arithmetic operation keypad in parallel:keysF :: F Click (CalcState -> CalcState)keysF = hBoxF (numbersF >*< operationsF)The internal state of the calculator is maintained by the abstract fudget stateSP, whichaccepts state modifying functions as its input and outputs the new values of the state underthese functions. The state is implemented using the standard mapAccumlSP function which51



requires a function that will specify how the state is to be modi�ed and what the outputvalue will be. In this case the output value is the same as the modi�ed state hence in thetuple returned by modify the two components are the same.stateSP :: CalcState -> SP (CalcState -> CalcState) CalcStatestateSP state = mapAccumlSP modify statewhere modify st f = let st' = f stin (st', st')The semantics of the calculator logic is speci�ed by the evalOperation and evalDigit func-tions just as it was for the widgets version, see Section A.1.1.A.1.4 Comparison of Widget and Fudget GUIsThe two interfaces developed in the preceding sections look identical on screen. The code isalso remarkably similar, with almost all of the widget functions having obvious correspondingfunctions in the fudget version. The stream processors, stateSP and displayState, cor-respond to the keyOp function of the widget version. However, one important di�erence isthat in the widget version the abstractions for keypads require the actions that are to beperformed, when the keys are pressed, as arguments. In the fudget version these actions canbe determined at a later point as the keypads simply emit a value indicating which key hasbeen pressed.A.2 A Combination LockAt the Glasgow GUIFest in 1995, one of the suggestions for applications to test GUI develop-ment systems was a combination lock. The idea is to build a graphical component modellinga combination lock that can be used wherever a button component could be used.A.2.1 A Widget Combination LockThe combination lock we model here is based on a digital combination lock with a keypadfor entering combinations. We will consider only numeric combinations here, but it is easy toextend the code to handle combinations using other symbols.Firstly, we will need a graphical component modelling a keypad. Fortunately, we havealready described a numeric keypad in the implementation of the calculator widget (Sec-tion A.1.2), and we can reuse the numberPadW function for the combination lock.The combination lock needs to store the current code entered as part of its state. Thebehaviour exhibited when the correct code is entered can be changed by the user of thecombination lock widget, and so must also be stored as part of its state:type Code = [Int]type CombState = (Code, GUI ())type CombStVar = Ref CombStateCodes are represented as lists of integer digits. The �rst component in the CombState typerepresents the code that the user has entered. The second component in the CombState typerepresents the behaviour of the combination lock when the correct code has been entered.The combination lock widget must be able to be used wherever a regular button widgetcould be used. All button widgets must be instances of the Editable type class, and so we52



must make the combination lock widget an instance too. A data type declaration is requiredso that we can represent combination locks in a form that we can use to make an instance ofthe Editable type class:data CombinationLock = CombinationLock CombStVarThis representation allows us to manipulate the combination lock through its state. We canmake CombinationLock an instance of the Editable type class, but before we do this, wemust make it an instance of the Control type class, as this is a subclass of the Editable typeclass: instance Control CombinationLock wheresetText (CombinationLock st) text = return ()getText (CombinationLock st) = return ""Here for simplicity, we do not make use of the associated text for a combination lock controland implement dummy behaviour for altering or retrieving this text. This is expressed by theimplementations of the setText and getText functions that have no side e�ects and returndummy values. Now we can de�ne an instance of the CombinationLock data type for theButton type class:instance Editable CombinationLock whereonChange (CombinationLock st) handler'= do (current, handler) <- getRef stsetRef st (current, handler')onCommit (CombinationLock st) handler = return ()The implementation of the onChange function simply replaces the current handler used bythe combination lock when the correct code is entered.The actual combination lock is described by a widget combinator, combLockW, whichcreates a widget that, when realized in a window, will create an initial value of the combinationlock's state, realize the keypad and return a value that can be used to further manipulate thecombination lock:combLockW :: Code -> GUI () -> Widget CombinationLockcombLockW code handler = do st <- stateW ([], handler)numberPadW (match st (reverse code))return (CombinationLock st)The master code that is passed to the match function is reversed as this simpli�es the codefor this function.The logic behind the combination lock is all described by the match function that expressesthe behaviour exhibited by the keypad when one of the buttons in the keypad is pressed.This function must construct the new code entered by the user by adding the new digitcorresponding to the button pressed to the existing code. It must also compare the newcode entered to the master code, if the two match then the behaviour speci�ed by the secondcomponent of the state, the handler, must be performed. If the codes do not match, then wesimply store the new code entered by the user in the state. However, the code entered by theuser must never exceed the length of the master code, and so the new code entered by theuser is truncated to the length of the master code:53



Figure A.2: A counter using a combination lockmatch :: CombStVar -> Code -> Int -> GUI ()match st master x = do (current, handler) <- getRef stlet current' = take (length master) (x : current)if current' == master thendo handlersetRef st ([], handler)elsesetRef st (current', handler)If the code entered by the user does match the master code, then the currently entered codeis reset to an empty list, representing an empty code, so that the combination lock is reset,ready to receive another combination attempt.It is quite simple to modify the counter application from Figure 3.2 to use a combinationlock instead of a regular push button. The only function that needs to be changed is thecounter function:counter :: Int -> Widget CombinationLockcounter init= vbox (do (display, update) <- stateTextW display_size 0combLockW [1,2,3] (update (+1)))The master code is chosen to be 123, and when this code is entered a function to add oneto its argument is sent to the Widget created by the stateTextW combinator. The resultingapplication can be seen in Figure A.2.
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Appendix BSource CodeThis section provides the Haskell source code for the Embracing Windows framework. Theframework also requires a modi�ed version of the Hugs functional programming system thatimplements the monadic primitives for windowing operations. These primitives are imple-mented in C, in a similar way to the primitives already built-in to Hugs for teletype I/O. Thesource code for these primitives is not included here.B.1 I/O Primitives and Library FilesB.1.1 TypesThis module contains the type de�nitions for particular types used throughout the EmbracingWindows framework. It also includes data type de�nitions for built-in types correspondingto window handles, device contexts, and objects. Objects are used for drawing graphics;currently, the only type of object available is a pen.> module Types> wherePairs of integers are used very frequently, and so we de�ne a type for them:> type Vector = (Int, Int)Vectors are used in many di�erent ways to represent points, sizes and rectangles. We de�netype synonyms and useful access functions for each of these cases to make the code easier tocomprehend. Using data type de�nitions would be better as we gain stricter type checkingand could also make use of the Haskell 1.3 record syntax which gives us the selector functionsautomatically:> type Point = Vector> type Size = Vector> type Rect = (Vector, Vector)> getX :: Size -> Int> getX (x, _) = x> getY :: Size -> Int> getY (_, y) = y> getSize :: Rect -> Size 55



> getSize (_, size) = size> getPoint :: Rect -> Point> getPoint (point, _) = point> type Colour = IntThe following data types are built-in to the modi�ed verision of Hugs, and are used to rep-resent windows, device contexts, and objects respectively. An null value for the Window datatype is de�ned, which is nullWindow useful for cases when a value of type Window is requiredbut not really important. Equality is de�ned on values of type Window, as this is useful indetermining if an event is related to a speci�c window.> data Window> data DC> data Object> primitive nullWindow "primNullWindow" :: Window> primitive primEqWindow :: Window -> Window -> Bool> instance Eq Window where> (==) = primEqWindowAn event in Windows 95 is comprised of a window, message identi�er, and two extrainteger parameters for event speci�c information. We model this as a 4-tuple:> type Event = (Window, Int, Int, Int)B.1.2 Monadic PrimitivesThis module contains the de�nitions of the primitives required for the windows interface.There are three classes of primitives, event loop primitives, window primitives, and graphicprimitives.> module Windows_API> where> import TypesThe basic event loop primitives include primitives for starting an event loop, passing an eventto the default handler, and for quiting an event loop:> primitive primEventLoop :: (Event -> IO Int) -> IO ()> primitive primDefaultHandler :: Event -> IO Int> primitive primQuitEventLoop :: IO ()The windowing primitives provide functions for creating and destroying windows, setting andretrieving the caption of a window, setting and retrieving the size of a window, retrievinga list of the open windows, and setting the visibility of a window. The window creationfunction takes a string value as its �rst argument that determines the window class to use.A window class can be used in Windows 95 to specify the initial parameters of a window. Anumber of window classes are prede�ned in Windows 95, such as \button", \edit", \static",corresponding to button controls, editable text �eld controls, and static text labels. Theprimitive for obtaining a list of open windows is used to provide a default behaviour forexiting from an application, by automatically closing any open windows. The �rst argumentto the primShowWindow primitive is used to specify whether a window should be made visibleor invisible. The value True indicates that the window should be made visible, the valueFalse indicates that the window should be made invisible.56



> primitive primCreateWindow :: String -> Window -> Bool -> IO Window> primitive primDestroyWindow :: Window -> IO ()> primitive primSetWindowText :: Window -> String -> IO ()> primitive primGetWindowText :: Window -> IO String> primitive primSetWindowRect :: Window -> Rect -> IO ()> primitive primGetWindowRect :: Window -> IO Rect> primitive primGetWindows :: IO [Window]> primitive primShowWindow :: Bool -> Window -> IO ()Two primitives are provided for applications that require some notion of timing to operate.The �rst primitive sets a timer, that will cause a special event corresponding to a tick tooccur at speci�c intervals of time. The second primitive stops such ticks from occuring byremoving the timer:> primitive primSetTimer :: Window -> Int -> Int -> IO ()> primitive primKillTimer :: Window -> Int -> IO ()The following primitives are useful for drawing graphics. The �rst two are used to obtain andrelease device contexts needed for drawing. Only two basic drawing primitives are supported,for moving to and drawing a line to a particular point in a window. There are many otherprimitives that could have been included, such as ones for drawing circles or polygons, butwe omit these for reasons of simplicity, and also most of these more complicated primitivescan be encoded using the basic ones provided here. Support for drawing text is provided bythe primDisplayText primitive. Objects are used to alter the device context, the only onecurrently provided is the pen. Primitives are speci�ed for selecting an object into a devicecontext, and for deleting an object from memory. A simple pen object creation primitive isalso supplied. Finally the primBeginPaint and primEndPaint primitives are supported toobtain and release a device context for drawing in a window in response to a paint message:> primitive primGetDC :: Window -> IO DC> primitive primReleaseDC :: Window -> DC -> IO ()> primitive primMoveTo :: DC -> Int -> Int -> IO ()> primitive primLineTo :: DC -> Int -> Int -> IO ()> primitive primDisplayText :: DC -> Int -> Int -> String -> IO ()> primitive primSelectObject :: DC -> Object -> IO Object> primitive primDeleteObject :: Object -> IO Bool> primitive primCreatePen :: Int -> Colour -> IO Object> primitive primBeginPaint :: Window -> IO DC> primitive primEndPaint :: Window -> IO ()B.1.3 Window ConstantsThis module contains de�nitions for constants that are speci�c to the Windows 95 system.> module Window_Constants> whereThe following constants determine the extra space that window borders and menus occupyin addition to the main client window area: 57



> window_extra_x = 8 :: Int> window_extra_y = 27 :: IntB.1.4 TableThe state maintained in the GUI monad is stored in tables. This module provides a simpleimplementation of tables.> module Table> whereA table is represented as an association list:> type Table k e = [(k, e)]A null table is representated as an empty association list:> nullTable :: Table k e> nullTable = []The following functions are useful auxillary functions for comparing keys and retrieving thevalue from an entry in an association list:> keyMatches :: Eq k => k -> (k, e) -> Bool> keyMatches k (k', _) = k == k'> getEntry :: (k, e) -> e> getEntry (_, e) = eThe rest of the functions in this module provide the main interface to tables. The functionlookup to retrieve the value corresponding to a particular key is missing here, as this functionis prede�ned by the Haskell 1.3 prelude �le. The update function can be used to update thecontents of a table. The addEntry and removeEntry functions can be used to add and removeassociations from a table:> update :: Eq k => k -> (e -> e) -> Table k e -> Table k e> update k f [] = []> update k f (t:ts) | keyMatches k t = (k, f (getEntry t)) : ts> | otherwise = t : update k f ts> addEntry :: Eq k => k -> e -> Table k e -> Table k e> addEntry k e t = (k, e) : (removeEntry k t)> removeEntry :: Eq k => k -> Table k e -> Table k e> removeEntry k [] = []> removeEntry k ((k', e'):es) | k' == k = removeEntry k es> | otherwise = (k', e') : removeEntry k esB.1.5 Event loop primitivesThis module declares a type class that allows us to refer to the monadic primitives for eventloops by the same name regardless of the monad that the primitives have been lifted into. Aninstance of the type class is provided for the IO monad, which allows us to use the monadicprimitives as they are declared in the Windows API module.58



> module EventSys> where> import Types> import Windows_API> class Monad m => EventSystem m where> eventLoop :: (Event -> IO Int) -> m ()> defaultHandler :: Event -> m Int> quitEventLoop :: m ()> instance EventSystem IO where> eventLoop = primEventLoop> defaultHandler = primDefaultHandler> quitEventLoop = primQuitEventLoopB.1.6 Window system primitivesThis module declares a type class that allows us to refer to the monadic primitives for basicwindow operations by the same name regardless of the monad that the primitives have beenlifted into. An instance of the type class is provided for the IO monad, which allows usto use the monadic primitives as they are declared in the Windows API module. A windowsystem is assumed to be event based and so the context for the WindowSystem type classincludes the EventSystem type class. The WindowSystem type class includes a method notmentioned in the paper, createWindow. This is a more primitive window creation functionthat createShellWindow and is useful for creating controls and child windows as well as shellwindows.> module WinSys> where> import Types> import Windows_API> import EventSys> class EventSystem m => WindowSystem m where> createWindow :: String -> Window -> Bool -> m Window> createShellWindow :: String -> m Window> destroyWindow :: Window -> m ()> setWindowCaption :: Window -> String -> m ()> getWindowCaption :: Window -> m String> setWindowRect :: Window -> Rect -> m ()> getWindowRect :: Window -> m Rect> getWindows :: m [Window]> showWindow :: Bool -> Window -> m ()> setTimer :: Window -> Int -> Int -> m ()> killTimer :: Window -> Int -> m ()> getDC :: Window -> m DC> releaseDC :: Window -> DC -> m ()> beginPaint :: Window -> m DC> endPaint :: Window -> m ()> instance WindowSystem IO where> createWindow = primCreateWindow> createShellWindow = primCreateShellWindow> destroyWindow = primDestroyWindow> setWindowCaption = primSetWindowText 59



> getWindowCaption = primGetWindowText> setWindowRect = primSetWindowRect> getWindowRect = primGetWindowRect> getWindows = primGetWindows> showWindow = primShowWindow> setTimer = primSetTimer> killTimer = primKillTimer> getDC = primGetDC> releaseDC = primReleaseDC> beginPaint = primBeginPaint> endPaint = primEndPaintThe createWindow primitive is a very general window creation function, but it is quite cum-bersome to use. A simpler function for creating shell windows can easily be de�ned as:> primCreateShellWindow :: WindowSystem m => String -> m Window> primCreateShellWindow title> = do window <- createWindow "HugsWindow" nullWindow True> setWindowCaption window title> return windowB.1.7 Mutable VariablesThis module declares a type class encapsulating the operations that characterise mutablevariables. This allows the names for these operations to be reused regardless of the monad weare working in. The built-in data type for mutable variables and their associated operationsare also declared. These built-in operations are used to declare an instance of the MutVarstype class, so that the operations may be used in the IO monad.> module IORef> where> class MutVars m where> newRef :: a -> m (Ref a)> getRef :: Ref a -> m a> setRef :: Ref a -> a -> m ()> data Ref a> primitive primNewRef "newRef" :: a -> IO (Ref a)> primitive primGetRef "getRef" :: Ref a -> IO a> primitive primSetRef "setRef" :: Ref a -> a -> IO ()> instance MutVars IO where> newRef = primNewRef> getRef = primGetRef> setRef = primSetRefEquality on mutable variables is declared as it is in the IORef module since this does notdepend upon the monad in which the mutable variable operations are lifted into:> primitive eqRef :: Ref a -> Ref a -> Bool> instance Eq (Ref a) where> (==) = eqRef 60



B.2 Event HandlingB.2.1 GUIThis module de�nes the GUI monad and associated functions. The state that the GUI monadmaintains is stored in a table containing tables that can be used to map an event to theappropriate behaviour. This whole structure is stored in a mutable variable.> module GUI> where> import Types> import Table> import MutVar> import MessageEvent handlers are functions that take an event as an argument and process it. The responseto an event may well involve manipulation of windows, and the event handlers themselves,and so the result of an event handler is a value of the GUI monad.> type EventHandler = Event -> GUI ()The state maintained by the GUI monad is stored in a table of type Window Table whoseentries are tables themselves. The whole state is stored as a mutable variable.> type EventHandlers = Table EventType EventHandler> type Window_Table = Table Window EventHandlers> type GUIState = Window_Table> type GUIStateVar = Ref GUIStateThe following functions are useful for accessing and changing the state maintained by the GUImonad.> getWindowTable :: GUIState -> Window_Table> getWindowTable = updateWindowTable id> setWindowTable :: Window_Table -> GUIState -> GUIState> setWindowTable window_table = updateWindowTable (\_ -> window_table)> updateWindowTable :: (Window_Table -> Window_Table) -> GUIState -> GUIState> updateWindowTable f window_table = f window_tableThe GUI monad is a state reader monad. The state encapsulated by this monad is a mutablevariable that stores the responses required for particular events. Because the monad is a statereader monad, the mutable variable itself cannot be changed, but the value it contains canbe changed, and thus the monad can act like a normal state transformer monad.> newtype GUI a = GUI (GUIStateVar -> IO a)> instance Functor GUI where> map f (GUI g) = GUI (\st -> do a <- g st> return (f a))> instance Monad GUI where> return x = GUI (\st -> return x)> GUI g >>= f = GUI (\st -> do a <- g st> let GUI h = f a> h st) 61



The getenvGUI function is useful for extracting the mutable variable containing the stateencapsulated by the GUI monad.> getenvGUI :: GUI GUIStateVar> getenvGUI = GUI returnOperations of type IO a can be lifted into the GUI monad by simply ignoring the mutablevariable containing the state encapsulated by the GUI monad.> liftGUI :: IO a -> GUI a> liftGUI f = GUI (\_ -> f)Since the GUI monad uses mutable variables, it is useful to have versions of the operationson mutable variables that work in the GUI monad. This can be achieved by providing aninstance of the MutVars type class for the GUI type, with the methods being implemented aslifted versions of the original mutable variable primitives.> instance MutVars GUI where> newRef a = liftGUI (newRef a)> getRef a = liftGUI (getRef a)> setRef a x = liftGUI (setRef a x)The following functions provide a means to access and modify the state encapsulated bythe GUI monad. The caller of these functions needs no knowledge of the fact that the state isstored in a mutable variable.> updateGUIState :: (GUIState -> GUIState) -> GUI GUIState> updateGUIState f = do st <- getenvGUI> v <- getRef st> setRef st (f v)> return v> getGUIState :: GUI GUIState> getGUIState = updateGUIState id> setGUIState :: GUIState -> GUI ()> setGUIState state = do updateGUIState (\_ -> state)> return ()To make the GUI monad useful, we have to de�ne a function to turn a value of type GUI ainto one of type IO a so that it can be executed in a program. This requires supplying aninitial value for the state that the GUI monad encapsulates.> startingWithGUI :: GUI a -> GUIStateVar -> IO a> startingWithGUI (GUI f) r = f rB.2.2 Event HandlersThis module de�nes a family of coercion functions that unpack information from the Eventdata type and pass it on to a function to process the event. The di�erent types of events areidenti�ed by a magic number speci�c to the Microsoft Windows 95 system.> module EventHandlers> where> import Types> import Message 62



> import GUI> import Graphics> handleDestroy :: (Window -> GUI ()) -> Event -> GUI ()> handleDestroy f (w, 2, _, _) = f w> handlePaint :: (Window -> Draw ()) -> Event -> GUI ()> handlePaint f (w, 15, _, _) = paintInWindow w (f w)The event processing function that the handleLButtonDown coercion function takes as its �rstargument receives the window the mouse button was pressed in, a boolean to indicate whetherthe mouse button was single or double clicked, and a vector describing the position of themouse cursor when the mouse button was pressed. In a similar way, the handleLButtonUpcoercion function passes on the window the mouse cursor was clicked in, and its position tothe event processing function.> handleLButtonDown :: (Window -> Bool-> Point -> GUI ()) -> Event -> GUI ()> handleLButtonDown f (w, 513, _, lparam) = f w False (getVector lparam)> handleLButtonDown f (w, 515, _, lparam) = f w True (getVector lparam)> handleLButtonUp :: (Window -> Point -> GUI ()) -> Event -> GUI ()> handleLButtonUp f (w, 514, _, lparam) = f w (getVector lparam)The event processing function used with the handleCommand coercion function expectsfour parameters, the associated window, an identi�er, handle of control, and a noti�cationcode. The noti�cation code indicates whether the event is a noti�cation from a control, amenu selection, or from a keyboard accelerator for a menu. The identi�er speci�es whichcontrol or menu item is involved. The handle of the control speci�es which control sent thenoti�cation if the event represents a control noti�cation, otherwise this value is null. childcontrol, The handleCommand coercion function> handleCommand :: (Window -> Int -> Int -> Int -> GUI ()) -> Event -> GUI ()> handleCommand f (w, 273, wp, lp) = f w (loword wp) lp (hiword wp)The handleKey coercion function passes on parameters to its event processing functionindicating the window involved, a code for the key pressed, a boolean representing if the keywas pressed or released, and two integers describing the number of times the keystroke isrepeated and the state of modi�er keys such as shift, alt, and ctrl.> handleKey :: (Window -> Int-> Bool -> Int -> Int -> GUI ()) -> Event -> GUI ()> handleKey f (w, 256, wp, lp) = f w wp True (loword lp) (hiword lp)> handleKey f (w, 257, wp, lp) = f w wp False (loword lp) (hiword lp)The integer passed to the event processing function by the handleQuit coercion functionindicates the exit code, describing whether the application is being quitted for normal orabnormal reasons.> handleQuit :: (Window -> Int -> GUI ()) -> Event -> GUI ()> handleQuit f (w, 18, wp, _) = f w wpThe integer handleTimer passes to its event processing function is an identi�er for theparticular timer involved.> handleTimer :: (Window -> Int -> GUI ()) -> Event -> GUI ()> handleTimer f (w, 275, wp, _) = f w wp 63



handleSize passes an integer representing the type of sizing operation, such as maximiz-ing, minimizing, restoring, or normal window sizing, to the event processing function.> handleSize :: (Window -> Int -> Size -> GUI ()) -> Event -> GUI ()> handleSize f (w, 5, wp, lp) = f w wp (getVector lp)B.2.3 MessageThis module contains an event type for the Windows 95 system, and some auxillary functionsthat are useful for packing/unpacking values from an event.> module Message> where> import TypesThe hiword and loword functions extract the high word, and low word from a 32 bit value.> hiword :: Int -> Int> hiword w = w `div` 65536> loword :: Int -> Int> loword w = w `mod` 65536Vectors are commonly packed into a 32 bit value, and require unpacking using the hiwordand loword functions, getVector performs this unpacking.> getVector :: Int -> Vector> getVector lparam = (loword lparam, hiword lparam)The makeParam function is useful for constructing a 32 bit value from two 16 bit words.> makeParam :: Int -> Int -> Int> makeParam hi lo = lo + (hi * 65536)The event data type supports only a handful of the possible events for the Windows 95system. The events supported are window destruction, window painting, mouse button clicks,commands (menu selections, and control noti�cations), key presses, quitting applications,timer events, and window sizing. The getEventType function extracts the type of event froma value of type Event by examining the second parameter, the message parameter.> data EventType = Destroy> | Paint> | LButtonDown> | LButtonUp> | Command> | Key> | Quit> | Timer> | Size> | Unknown> deriving Eq> getEventType :: Event -> EventType> getEventType (_, msg, _, _)> = case msg of> 2 -> Destroy> 15 -> Paint 64



> 513 -> LButtonDown> 514 -> LButtonUp> 515 -> LButtonDown> 273 -> Command> 256 -> Key> 257 -> Key> 18 -> Quit> 275 -> Timer> 5 -> Size> _ -> Unknown>B.2.4 Lifted FunctionsTo use the event loop primitives and the basic window operation primitives in the GUImonad requires appropriate instance declarations for the EventSystem and WindowSystemtype classes. The implementation of the methods of these type classes simply uses the liftingfunction for the GUI monad to lift the primitives from the IO monad to the GUI monad.> module Lift> where> import WinSys> import GUI> instance EventSystem GUI where> eventLoop handler = liftGUI (eventLoop handler)> defaultHandler event = liftGUI (defaultHandler event)> quitEventLoop = liftGUI quitEventLoop> instance WindowSystem GUI where> createWindow c parent border = liftGUI (createWindow c parent border)> createShellWindow title = liftGUI (createShellWindow title)> destroyWindow window = liftGUI (destroyWindow window)> setWindowCaption window text = liftGUI (setWindowCaption window text)> getWindowCaption window = liftGUI (getWindowCaption window)> setWindowRect window layout = liftGUI (setWindowRect window layout)> getWindowRect window = liftGUI (getWindowRect window)> getWindows = liftGUI getWindows> showWindow state window = liftGUI (showWindow state window)> setTimer window id time = liftGUI (setTimer window id time)> killTimer window id = liftGUI (killTimer window id)> getDC window = liftGUI (getDC window)> releaseDC window dc = liftGUI (releaseDC window dc)> beginPaint window = liftGUI (beginPaint window)> endPaint window = liftGUI (endPaint window)
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B.3 The CoreB.3.1 WindowsThis �le is the main windows interface. It has functions for maintaining the state of a GUI,that is the event handlers that are in place to handle events.> module Windows> where> import Types> import Table> import GUI> import Message> import Lift> import WinSys> import MutVarThe following functions are used to process events. When an event occurs the mainHandlerfunction encapsulates the state of the application into the GUI monad, and passes the evento the processEvent function. This function looks up the event in the application's state,�rst looking for the table containing responses to events for the particular window that theevent is associated with, and then using the type of the event to determine the response. Ifno entry is found, then the response is determined by the default event handler, otherwise theresponse retrieved from the state is performed. If the response is determined by the defaultevent handler, then its return value must be passed back to the window system (this is anidiosyncrasy of the Windows 95 system).> getEventHandler :: GUIState -> Window -> EventType -> Maybe EventHandler> getEventHandler state window eventtype> = do let window_table = getWindowTable state> eventhandlers <- lookup window window_table> lookup eventtype eventhandlers> runEventHandler :: Maybe EventHandler -> Event -> GUI Int> runEventHandler Nothing event = defaultHandler event> runEventHandler (Just event_handler) event = do event_handler event> return 0> processEvent :: Event -> GUI Int> processEvent event = do let etype = getEventType event> (w, _, _, _) = event> state <- getGUIState> let event_handler = getEventHandler state w etype> runEventHandler event_handler event> mainHandler :: GUIStateVar -> Event -> IO Int> mainHandler st ce = startingWithGUI (processEvent ce) stThe initial state for all graphical applications is an empty table, which indicates that nowindows have been created, and that all events are to be processed using the default eventhandler.> initGUIState :: GUIState> initGUIState = nullTable 66



A graphical application is started using the startProg function, which creates the state tostore the table used for determining responses to events. The application is then given anopportunity to create windows, menus, buttons, and other graphical components, installingthe appropriate responses to events in the state. Finally the event loop is entered, and theapplication then becomes responsive to interaction from the user.> startProg :: GUI () -> IO ()> startProg w = do st <- newRef initGUIState> startingWithGUI w st> eventLoop (mainHandler st)The basic window creation primitive can be used to create so called child windows, whichhave another window as their parent, and exist inside this other window. A useful abstractionfor creating these windows, not only creates the window, but sets its position and size, andalso makes it visible.> mkChildWindow :: Window -> Rect -> GUI Window> mkChildWindow parent layout> = do window <- createWindow "HugsWindow" parent False> setWindowRect window layout> showWindow True window> return windowWhen a new window is created, we add a new entry to the state; this is a table thatwill contain the mappings between events and responses for the new window. This table isinitially empty indicating that all responses are to be determined by the default event handlerbuilt-in to the window system.> addWindow :: Window -> GUI ()> addWindow window> = do state <- getGUIState> let window_table = getWindowTable state> window_table' = addEntry window nullTable window_table> state' = setWindowTable window_table' state> case (lookup window window_table) of> Nothing -> setGUIState state'> Just _ -> return ()The following functions provide a simple interface for altering the responses to events that arestored in the graphical application's state. The functions support removing existing responsesfor events, and adding new responses for events.> addHandler :: Window -> EventType -> EventHandler -> GUI ()> addHandler window event handler> = do addWindow window> updateGUIState f> return ()> where f = updateWindowTable (update window (addEntry event handler))> removeHandler :: Window -> EventType -> GUI ()> removeHandler window event> = do updateGUIState f> return ()> where f = updateWindowTable (update window (removeEntry event))When an application wishes to shut itself down, it can call this function. Closing of openwindows is automatically taken care of by obtaining a list of all the open windows belonging to67



the application, and then destroying these windows. The state for the application is emptiedbefore destroying the windows so that the application does not process any messages relatingto the windows destruction.> quitApp :: GUI ()> quitApp = do window_list <- getWindows> updateGUIState f> mapM_ destroyWindow window_list> quitEventLoop> return ()> where f state = setWindowTable nullTable stateB.3.2 On HandlersThis module provides a family of functions useful for de�ning the behaviour of a graphicalapplication. The application's state is altered to set the behaviour in response to an event.Also, the information packed in the event structure is unpacked according to the type of theevent, requiring the programmer to supply a function using the unpacked information.> module OnHandlers> where> import Types> import GUI> import Windows> import EventHandlers> import Lift> import Windows_API> onDestroy :: Window -> (Window -> GUI ()) -> GUI ()> onDestroy window handler = addHandler window Destroy (handleDestroy handler)> onPaint :: Window -> (Window -> Draw ()) -> GUI ()> onPaint window handler = addHandler window Paint (handlePaint handler)> onLButtonDown :: Window -> (Window -> Bool -> Point -> GUI ()) -> GUI ()> onLButtonDown window handler> = addHandler window LButtonDown (handleLButtonDown handler)> onLButtonUp :: Window -> (Window -> Point -> GUI ()) -> GUI ()> onLButtonUp window handler> = addHandler window LButtonUp (handleLButtonUp handler)> onCommand :: Window -> (Window -> Int -> Int -> Int -> GUI ()) -> GUI ()> onCommand window handler = addHandler window Command (handleCommand handler)> onKey :: Window -> (Window -> Int -> Bool -> Int -> Int -> GUI ()) -> GUI ()> onKey window handler = addHandler window Key (handleKey handler)> onQuit :: Window -> (Window -> Int -> GUI ()) -> GUI ()> onQuit window handler = addHandler window Quit (handleQuit handler)> onTimer :: Window -> (Window -> Int -> GUI ()) -> GUI ()> onTimer window handler = addHandler window Timer (handleTimer handler)> onSize :: Window -> (Window -> Int -> Size -> GUI ()) -> GUI ()> onSize window handler = addHandler window Size (handleSize handler)68



A useful abstraction is to create a window with a particular title, and with a prede�nedresponse of shutting down the application when closed.> mkWindow :: String -> GUI Window> mkWindow text> = do window <- createShellWindow text> onDestroy window (\_ -> quitApp)> return windowB.3.3 ControlsThis module provides support for the built-in controls of a windowing system. A hierarchyof type classes is used to capture the commonalities between di�erent controls.> module Controls> where> import Types> import GUI> import Lift> import Windows> import OnHandlersA control has the concept of an associated piece of text, such as the label on a button, andalso has a particular size. These characteristics are captured by the Control type class:> class Control a where> setText :: a -> String -> GUI ()> getText :: a -> GUI String> setRect :: a -> Rect -> GUI ()> getRect :: a -> GUI RectAn editable control supports the concepts of change and commit. Change is when the contentsof an editable control changes as a result of interaction with the user. Commit is when thecontents of an editable control is �xed at its current value in response to a user action. Anexample of an editable control is an editable text �eld. Whenever the text of the text �eldis edited, the behaviour speci�ed by the onChange function is invoked. Commit occurs whenthe user presses the return key in the text �eld:> class Control a => Editable a where> onChange :: a -> GUI () -> GUI ()> onCommit :: a -> GUI () -> GUI ()> class Editable a => Button a where> setState :: a -> Bool -> GUI ()> getState :: a -> GUI BoolA push button is implemented by wrapping the built-in control inside of a transparent window.Both of the windows involved, the one for the control itself, and the transparent windowwrapping it and stored in the representation of a push button. This allows the button tobe easily manipulated. The operation of altering the text of the control uses the control'sown window, whereas altering the size of the control alters the size of both the control'swindow and the surrounding transparent window. The button's content is considered to havechanged whenever it is pushed, and thus the behaviour speci�ed by the onChange method isinvoked whenever this is the case. The position of a child window is speci�ed relatively to itscontaining parent window, thus the position of a wrapped control window is (0, 0).69



> data PushButton = PushButton Window Window> instance Control PushButton where> setText (PushButton _ button) text = setWindowCaption button text> getText (PushButton _ button) = getWindowCaption button> setRect (PushButton window button) (xy, wh)> = do setWindowRect window (xy, wh)> setWindowRect button ((0, 0), wh)> getRect (PushButton window _) = getWindowRect window> instance Button PushButton where> setState (PushButton _ _) state = return ()> getState (PushButton _ _) = return False> instance Editable PushButton where> onChange (PushButton window _) handler> = onCommand window (\w id ctl code -> handler)> onCommit (PushButton window _) handler = return ()An editable text �eld is implemented in a similar manner to a push button, except therequired responses for change and commit in the control are stored in the representation ofthe editable text �eld. This is necessary as the event indicating either a change or a commithas the same type. When changing the behaviour for either a change or a commit, we mustmaintain the behaviour for the other event, which we can retrieve from the editable text �eld'srepresentation:> data EditField = EditField Window Window (GUI ()) (GUI ())> instance Control EditField where> setText (EditField _ edit _ _) text = setWindowCaption edit text> getText (EditField _ edit _ _) = getWindowCaption edit> setRect (EditField window edit _ _) (xy, wh)> = do setWindowRect window (xy, wh)> setWindowRect edit ((0, 0), wh)> getRect (EditField window _ _ _) = getWindowRect window> instance Editable EditField where> onChange (EditField window button _ oncommit) handler> = onCommand window (\w id ctl code -> notify code button)> where notify n edit = if (n == 768) then handler> else if (n == 1792) then oncommit> else return ()> onCommit (EditField window button onchange _) handler> = onCommand window (\w id ctl code -> notify code button)> where notify n edit = if (n == 768) then onchange> else if (n == 1792) then handler> else return ()A text label need only be an instance of the Control type class as it has none of the charac-teristics of an editable control. As such a wrapping transparent window is not required:> data TextLabel = TextLabel Window> instance Control TextLabel where> setText (TextLabel window) text = setWindowCaption window text> getText (TextLabel window) = getWindowCaption window> setRect (TextLabel window) rect = setWindowRect window rect> getRect (TextLabel window) = getWindowRect windowWhen creating a control, we need to specify a string identifying the type of control to becreated, and a parent window. The basic window creation primitive does not automatically set70



the position and size of the control, or it's associated text. To provide this extra functionality,we de�ne a function mkControl, that also makes the control visible as well as setting itsposition and size.> mkControl :: String -> Window -> String -> Rect -> GUI Window> mkControl clss parent text size = do window <- createWindow clss parent True> setWindowRect window size> setWindowCaption window text> showWindow True window> return windowThe following functions are used to create instances of particular controls. For push buttonsand editable text �elds, a child window is used to wrap the control window. This makes theprocessing of noti�cation events from the control window easier to handle. Text labels haveno noti�cation events and so are not created inside of a child window:> mkPushButton :: Window -> String -> Rect -> GUI PushButton> mkPushButton parent text (xy, wh)> = do window <- mkChildWindow parent (xy, wh)> btn <- mkControl "button" window text ((0, 0), wh)> return (PushButton window btn)> mkEditField :: Window -> String -> Rect -> GUI EditField> mkEditField parent text (xy, wh)> = do window <- mkChildWindow parent (xy, wh)> edit <- mkControl "edit" window text ((0, 0), wh)> return (EditField window edit (return ()) (return ()))> mkTextLabel :: Window -> String -> Rect -> GUI TextLabel> mkTextLabel parent text (xy, wh)> = do window <- mkControl "static" parent text (xy, wh)> return (TextLabel window)B.3.4 GraphicsThis module provides support for drawing graphics in windows. A monad is introduced thatencapsulates the context required for drawing.> module Graphics> where> import Types> import WinSysDrawing in a window requires a device context, which is obtained in one of two ways dependingupon the situation. If the drawing is taking place in response to the special paint event, thenthe device context can be obtained by using the beginPaint function, and must be freedusing the endPaint function. For all other cases, a device context can be obtained using thegetDC function, and is freed using the releaseDC function. These functions are speci�c tothe Windows 95 system. The following two functions encapsulate these two ways of obtaininga device context:> drawInWindow :: Window -> Draw a -> GUI a> drawInWindow w d = do dc <- getDC w> result <- startingWithDraw dc d> releaseDC w dc 71



> return result> paintInWindow :: Window -> Draw a -> GUI a> paintInWindow w d = do dc <- beginPaint w> result <- startingWithDraw dc d> endPaint w> return resultThe Draw monad encapsulates a device context such that the programmer does not have tothread it throughout the code for drawing graphics. This monad is a state reader monad:> newtype Draw a = Draw (DC -> GUI a)> instance Functor Draw where> map f (Draw g) = Draw (\dc -> map f (g dc))> instance Monad Draw where> return x = Draw (\dc -> return x)> Draw g >>= f = Draw (\dc -> do a <- g dc> let Draw h = f a> h dc)> startingWithDraw :: DC -> Draw a -> GUI a> startingWithDraw dc (Draw d) = d dcArbitrary operations in the GUI monad can be lifted into the Draw monad simply by ignoringthe device context that is encapsulated by the Draw monad:> liftDraw :: GUI a -> Draw a> liftDraw a = Draw (\_ -> a)All operations from the EventSystem,WindowSystem and MutVars type classes are lifted intothe Draw monad, so that these operations are all available while drawing graphics:> instance EventSystem Draw where> eventLoop handler = liftDraw (eventLoop handler)> defaultHandler event = liftDraw (defaultHandler event)> quitEventLoop = liftDraw (quitEventLoop)> instance WindowSystem Draw where> createWindow clss parent brdr = liftDraw (createWindow clss parent brdr)> destroyWindow window = liftDraw (destroyWindow window)> setWindowCaption window text = liftDraw (setWindowCaption window text)> getWindowCaption window = liftDraw (getWindowCaption window)> setWindowRect window layout = liftDraw (setWindowRect window layout)> getWindowRect window = liftDraw (getWindowRect window)> getWindows = liftDraw getWindows> showWindow state window = liftDraw (showWindow state window)> setTimer window id time = liftDraw (setTimer window id time)> killTimer window id = liftDraw (killTimer window id)> getDC window = liftDraw (getDC window)> releaseDC window dc = liftDraw (releaseDC window dc)> beginPaint window = liftDraw (beginPaint window)> endPaint window = liftDraw (endPaint window)> instance MutVars Draw where> newRef a = liftDraw (newRef a)> getRef a = liftDraw (getRef a)> setRef a x = liftDraw (setRef a x) 72



A drawing system is characterised by operations for drawing lines, and text. It also supportsthe creation of pens with di�erent colours and widths. These ideas are encapsulated into theDrawingSystem type class:> class WindowSystem m => DrawingSystem m where> lineTo :: Point -> m ()> moveTo :: Point -> m ()> selectObject :: Object -> m Object> deleteObject :: Object -> m Bool> drawText :: Point -> String -> m ()> createPen :: Int -> Colour -> m ObjectThe Draw monad is a drawing system, as can be expressed by making it an instance of theDrawingSystem monad. The device context encapsulated by the Draw monad is used as anargument to the primitive functions for drawing in windows. Since the primitive functionswere not included in any of the type classes we have de�ned, they must be lifted into the GUImonad explicitly:> instance DrawingSystem Draw where> lineTo (x, y) = Draw (\dc -> liftGUI (primLineTo dc x y))> moveTo (x, y) = Draw (\dc -> liftGUI (primMoveTo dc x y))> selectObject obj = Draw (\dc -> liftGUI (primSelectObject dc obj))> deleteObject obj = Draw (\dc -> liftGUI (primDeleteObject obj))> drawText (x, y) text = Draw (\dc -> liftGUI (primDisplayText dc x y text))> createPen w c = Draw (\dc -> liftGUI (primCreatePen w c))> mapPoint :: (Int -> Int) -> Point -> Point> mapPoint f (x, y) = (f x, f y)An individual point can be drawn by drawing a line one unit in length. Coloured pointsrequire the creation of an appropriate pen with the correct colour and width:> drawPoint :: DrawingSystem m => Point -> m ()> drawPoint p = drawLine p (mapPoint (+1) p)> drawCPoint :: DrawingSystem m => Point -> Colour -> Int -> m ()> drawCPoint p c w = do pen <- createPen w c> oldpen <- selectObject pen> drawPoint p> selectObject oldpen> deleteObject pen> return ()A line can be drawn by moving to one end of the line, and drawing to the other end:> drawLine :: DrawingSystem m => Point -> Point -> m ()> drawLine p q = do moveTo p> lineTo qA �lled rectangle can be drawn by drawing a sequence of lines next to each other. An un�lledrectangle just requires the perimeter to be drawn:> drawFilledRect :: DrawingSystem m => Rect -> m ()> drawFilledRect ((x1, y1), (x2, y2))> = sequence [drawLine (x1, y) (x2, y) | y <- [y1..y2]]> drawRect :: DrawingSystem m => Rect -> m ()> drawRect ((x1, y1), (x2, y2)) = 73



> do moveTo (x1, y1)> lineTo (x1, y2)> lineTo (x2, y2)> lineTo (x2, y1)> lineTo (x1, y1)A polygon is a list a points that, when joined together, form the polygon. The last point inthe list is joined to the �rst point to close the shape:> type Polygon = [Point]> drawPolygon :: DrawingSystem m => Polygon -> m ()> drawPolygon [] = return ()> drawPolygon (p:ps) = sequence (moveTo p : map lineTo (ps ++ [p]))Colours are internally implemented as 32 bit values with the least signi�cant 8 bits repre-senting the amount of red, the next signi�cant 8 bits representing the amount of green, andthe next signi�cant 8 bits representing the amount of blue. This function should really be aprimitive as it assumes a particular internal represenation for the Colour type:> mkColour :: Int -> Int -> Int -> Colour> mkColour r g b = r + (g * 256) + (b * 65536)B.3.5 Embracing Windows FrameworkThis module imports all of the source code that comprises the Embracing Windows frame-work.> module EmbracingWindows> where> import Windows_Constants> import Windows> import OnHandlers> import Controls> import Graphics
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B.4 WidgetsThe widget system implemented in this section has been inspired by both TK-gofer andHaggis. The layout combinators and the use of a monadic representation for a graphicalcomponent in particular bear strong similarities to the ideas used in Haggis. The decision notto use concurrency and to keep the overall system relatively simple stem from the approachthat the TK-gofer system takes to expressing GUIs in a functional language.B.4.1 WidgetsThis module de�nes the data structure used for representing widgets, and associated manip-ulation functions.> module WidgetCore> where> import EmbracingWindowsA layout request is characterised by three values, a minimum size, a natural size, and anappropriate function for changing the size of the graphical component associated with thelayout request:> data LR = LR {minSize :: Size, natSize :: Size, sf :: Rect -> GUI ()}A widget is represented by a function whose argument identi�es the window the widget is tobe created inside of. The result of the function is a value of type GUI (a, [LR]), indicatingthat the function can perform I/O and that the result of this I/O is a pair comprising the realreturn value of the widget, and a list of layout requests. A list of layout requests is returnedin the pair, as the basic combinators for combining widgets do not alter the layout of thewidgets and so must preserve the layout requests:> newtype Widget a = Widget (Window -> GUI (a, [LR]))Combinators for the layout of widgets essentially take a list of layout requests and combinethem into a single layout request. A function that does this is referred to as a placer, and forwidgets the type of such functions is:> type WPlacer = [LR] -> LRIt is useful to de�ne a null sizing function that does nothing, and also a null layout requestwhich requests no screen space and uses a null sizing function:> nullSF :: Rect -> GUI ()> nullSF (_, _) = return ()> nullLR :: [LR]> nullLR = [LR (0, 0) (0, 0) nullSF]Widgets are combined using the two standard monadic combinators, thenW and returnW. Thelayout requests of widgets are combined by simply concatenating the two lists comprising thelayout requests to obtain the new layout request list. The Widget type is made an instance ofthe Monad type class, allowing the use of the built-in notation for de�ning monadic functions.A map function can be de�ned for widgets, allowing us to de�ne Widget as an instance of theFunctor type class: 75



> thenW :: Widget a -> (a -> Widget b) -> Widget b> thenW m n> = Widget (\win ->> do let Widget m' = m> (r, lra) <- m' win> let Widget n' = n r> (v, lrb) <- n' win> return (v, lra ++ lrb))> returnW :: a -> Widget a> returnW a = Widget (\win -> return (a, nullLR))> instance Monad Widget where> return = returnW> (>>=) = thenW> mapW :: (a -> b) -> Widget a -> Widget b> mapW f w = do x <- w> return (f x)> instance Functor Widget where> map = mapWA stateful widget has no on screen appearance, but creates a piece of mutable state andreturns a reference to it:> stateW :: a -> Widget (Ref a)> stateW init = Widget (\win -> do st <- newRef init> return (st, nullLR))A widget is realised in a window using the wopen function. This function creates a newwindow, and realises the widget inside of it. The widget returns a list of layout requests thatmust be combined to obtain a single layout request. The requests are combined by takingthe largest values for the minimum, and natural sizes in both the horizontal and verticaldimensions. This corresponds to a default layout combinator that places widgets in a pile ontop of one another. The newly created window is sized to the natural size of the combinedlayout request increased by a small amount corresponding to the width and height of windowborders and menus. The size of the window borders and menus is speci�c to Windows 95.The combined sizing function is called to ensure that the widget is sized correctly, sincethe combined layout request size may be di�erent to the size the components of the widgethave requested. When a sizing event occurs for the newly created window, the combinedsizing function is used to resize the widget. Finally the newly created window must be madevisible:> wopen :: String -> Widget a -> GUI Window> wopen text (Widget wid)> = do win <- mkWindow text> (_, lrs) <- wid win> let (LR _ (sx, sy) sf) = pileWP lrs> setWindowRect win ((0, 0), (sx + window_extra_x, sy + window_extra_y))> sf ((0, 0), (sx, sy))> onSize win (\w state xy -> sf ((0, 0), xy))> showWindow True win> return winThe following function de�nes a widget placer for placing widgets in a pile. The combinedminimum and natural sizes are obtained by taking the maximum values for these sizes in both76



the horizontal and vertical dimensions of all the individual layout requests. Sizing functionsare combined in by simply passing the new size to all of the sizing functions unaltered:> pileWP :: WPlacer> pileWP lrs = foldr1 pile2 lrs> where> pile2 (LR mina nata sfa) (LR minb natb sfb)> = let newsf rect = do sfa rect> sfb rect> in (LR (pairmax mina minb) (pairmax nata natb) newsf)> pairmax (x, y) (x', y') = (max x x', max y y')B.4.2 Layout WidgetsThis module contains layout combinators and other layout functions.> module LayoutWidgets> where> import WidgetCoreA widget placer can be used to layout widgets with the placerW function, taking a widgetplacer and a widget as arguments. The widget placer is used to combine the list of layoutrequests associated with the widget into a single layout request. Finally, a new widget isconstructed with a singleton list of layout requests with the combined layout request as itselement:> placerW :: WPlacer -> Widget a -> Widget a> placerW placer (Widget wid)> = Widget (\win -> do (a, lrs) <- wid win> return (a, [placer lrs]))A simple widget placer, is the horizontal widget placer. This combines widgets by placingthem next to each other horizontally. The minimum and natural sizes of each of the widgetsinvolved are combined by summing the horizontal dimensions and taking the maximum ofthe vertical dimensions. A new sizing function splits up the allocated screen space betweenthe widgets according to their individual requests. A widget whose natural and minimumsizes are the same will always receive the screen space it asked for, possibly at the expense ofwidgets whose natural and minimum sizes di�er:> horizontalWP :: WPlacer> horizontalWP lrs = let newmin = foldr1 f (map minSize lrs)> newnat = foldr1 f (map natSize lrs)> in LR newmin newnat (newsf lrs)> where> f (x, y) (x', y') = (x + x', max y y')> diff (LR (x, _) (x', _) _) = x' - x> g [] _ _ _ _ _ = return ()> g (lr:lrs) offset ay h a b = do let (LR (x, y) (x', _) sf) = lr> width = if b /= 0 then> x' + (((x' - x) * a) `div` b)> else 0> width' = max x width> sf ((offset, ay), (width', max y h))> g lrs (offset + width') ay h a b> newsf lrs ((ax, ay), (w, h)) = do let a = sum (map diff lrs)> x = sum (map (fst . natSize) lrs)> g lrs ax ay h (w - x) a77



The horizontalWP widget placer is used to de�ne the hbox layout combinator:> hbox :: Widget a -> Widget a> hbox = placerW horizontalWPA widget placer similar to the horizontalWP widget placer, combines widgets by placing themnext to each other vertically. The logic behind this widget placer is identical to that for thehorizontalWP widget placer, except that the horizontal and vertical dimensions are swappedaround. Abstracting away from this leads to the notion of a transpose combinator that wouldtake a widget placer and return a new widget placer identical to the original except that thehorizontal and vertical dimensions are 
ipped. Unfortunately, the choice of representation oflayout requests makes it di�cult to de�ne such a combinator, as the sizing function is notabstract enough. The sizing function is really a combination of two functions, one splitting arectangle into a list of rectangles, and the other using this list of rectangles to size the widgets.A transpose combinator needs to be able to modify the list of rectangles before the widgetsare sized using them. The modi�cation would 
ip the horizontal and vertical dimensions.The representation we have chosen, however, does not make the distinction between splittinga rectangle into a list of rectangles, and actually sizing the widgets using this list. As a resultof this, we cannot modify the list of rectangles and so cannot write a transpose combinator.Instead we duplicate the logic from the horizontalWP widget placer and manually modifythe code to 
ip the horizontal and vertical dimensions:> verticalWP :: WPlacer> verticalWP lrs = let newmin = foldr1 f (map minSize lrs)> newnat = foldr1 f (map natSize lrs)> in LR newmin newnat (newsf lrs)> where> f (x, y) (x', y') = (max x x', y + y')> diff (LR (_, y) (_, y') _) = y' - y> g [] _ _ _ _ _ = return ()> g (lr:lrs) ax offset w a b = do let (LR (x, y) (_, y') sf) = lr> height = if b /= 0 then> y' + (((y' - y) * a) `div` b)> else 0> height' = max y height> sf ((ax, offset), (max x w, height'))> g lrs ax (offset + height') w a b> newsf lrs ((ax, ay), (w, h)) = do let a = sum (map diff lrs)> y = sum (map (snd . natSize) lrs)> g lrs ax ay w (h - y) a> vbox :: Widget a -> Widget a> vbox = placerW verticalWPAdding a margin to a widget is a useful layout abstraction, and we provide three functionsfor doing this. The �rst adds a margin to the top and bottom of a widget, the second adds amargin to the left and right, and the last places a margin all the way around a widget:> vmargin :: Int -> Widget a -> Widget a> vmargin m w = vbox (do glue> val <- w> glue> return val)> where glue = space (m, m)> hmargin :: Int -> Widget a -> Widget a 78



> hmargin m w = hbox (do glue> val <- w> glue> return val)> where glue = space (m, m)> margin :: Int -> Widget a -> Widget a> margin m w = hmargin m (vmargin m w)It is sometimes useful to place widgets in a grid, the matrix layout combinator can be usedfor this. The �rst argument to this layout combinator speci�es the width of the grid in termsof the number of widgets placed horizontally on one row. The second argument is a list of thewidgets to be used to �ll the grid. Combining widgets using this layout combinator resultsin a new widget, whose return value is a function. This function can be used to obtain thereturn values of the constituent widgets by passing it a vector indicating which widget in thegrid to get the return value of:> matrix :: Int -> [Widget a] -> Widget (Vector -> a)> matrix n ws> = do aws <- vbox (accumulate (map (hbox . accumulate) (splitsegs n ws)))> let retwid (x, y) = (aws!!y)!!x> return retwid> splitsegs :: Int -> [a] -> [[a]]> splitsegs n = takeWhile (not . null) . map (take n) . iterate (drop n)Space widgets have no behaviour, but do take up screen space. Three functions are de�nedfor constructing space widgets. The �rst constructs a space widget taking up a speci�edamount of horizontal space, while the second constructs a widget taking up a speci�ed ofvertical space. Finally, a combination of these two functions is used to construct a spacewidget taking up a speci�c amount of horizontal and vertical space:> hspace :: Int -> Widget ()> hspace n = Widget (\win -> return ((), [LR (n,0) (n,0) nullSF]))> vspace :: Int -> Widget ()> vspace n = Widget (\win -> return ((), [LR (0,n) (0,n) nullSF]))> space :: Size -> Widget ()> space (x, y) = do hspace x> vspace yB.4.3 Standard WidgetsThis module contains de�nitions of standard library widgets, such as push buttons, editabletext �elds, and labels.> module WidgetLib> where> import EmbracingWindows> import WidgetCore> import LayoutWidgetsA button widget is speci�ed by the text label, size of the widget, and a value of type GUI() indicating the behaviour of the button when pressed. The layout request for the widget79



indicates that the button can shrink or grow to �t the space it is allocated, since its minimumsize is a zero size rectangle. An editable text �eld widget, and text label widget are constructedin a similar fashion to the button widget. However note, that the layout request for text labelsspeci�es the minimum and natural sizes to be the same indicating that the widget cannotshrink or grow in size:> buttonW :: String -> Size -> GUI () -> Widget PushButton> buttonW text (w, h) eh> = Widget (\win ->> do btn <- mkPushButton win text ((0, 0), (w, h))> onChange btn eh> let sizefun size = setRect btn size> return (btn, [LR (0,0) (w, h) sizefun]))> editW :: String -> Size -> Widget EditField> editW text (w, h)> = Widget (\win ->> do edit <- mkEditField win text ((0, 0), (w, h))> let sizefun size = setRect edit size> return (edit, [LR (0,0) (w, h) sizefun]))> textW :: String -> Size -> Widget TextLabel> textW text (w, h)> = Widget (\win ->> do static <- mkTextLabel win text ((0, 0), (w, h))> let sizefun size = setRect static size> return (static, [LR (w,h) (w, h) sizefun]))The concept of an abstract widget that has no visual appearance is quite useful, and a goodexample of such a widget is a timer widget. A timer widget has no visual appearance,but can be used to perform actions on a regular basis. The widget construction function,createTimer, takes a �rst argument specifying a time interval. The timerTick function isused to set the behaviour to occur after this time interval has elapsed:> data TimerControl = TimerControl Window> timerW :: Int -> Widget TimerControl> timerW interval = Widget (\win -> do timewin <- mkWindow ""> setTimer timewin 0 interval> return (TimerControl timewin, nullLR))> createTimer :: Int -> GUI TimerControl> createTimer interval> = do timewin <- mkWindow ""> setTimer timewin 0 interval> return (TimerControl timewin)> timerTick :: TimerControl -> GUI () -> GUI ()> timerTick (TimerControl window) handler = onTimer window (\w id -> handler)A stateful text label combines the standard text label widget with a piece of state. The valueof type a supplied as the third argument speci�es the initial value of the state. The widgetreturns a pair, the �rst value of which can be used to manipulate the text label, while thesecond value is a function that can be used to modify the state of the widget:> stateTextW :: Show a => Size -> a -> Widget (TextLabel, ((a -> a) -> GUI ()))> stateTextW size init 80



> = do st <- stateW init> label <- textW (show init) size> let update f = do v <- getRef st> let v' = f v> setRef st v'> setText label (show v')> return (label, update)A labelled edit widget, as described in Section 3.3:> labelledEditW :: String -> Size -> Widget EditField> labelledEditW label size = hbox (do textW label size> editW "" size)B.4.4 Widgets SystemThis module imports all of the source code that comprises the Widget system.> module Widgets> where> import WidgetCore> import LayoutWidgets> import WidgetLib
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B.5 FudgetsThe fudget system implemented here is based upon the original fudgets implementation. Thelayout combinators and stream processor functions are mostly identical or slightly modi�edversions of their counterparts from the original fudget implementation. The representationchosen for fudgets is a modi�ed version of that proposed by Reid and Singh, and here theassociated combinators are modi�ed versions of the ones they proposed. The implementationof the library widgets is new, although based in some part upon the ideas of Reid and Singh.B.5.1 FudgetsThis module de�nes the representation for a fudget and some basic functions for manipulatingfudgets.> module FudgetCore> where> import EmbracingWindowsLayout is handled in the Fudget system in a similar way to the Widget system, using layoutrequests. A layout request speci�es a preferred size and two booleans. The booleans indicatewhether the fudget can accept a di�erent size in either of the two dimensions, horizontal andvertical. Again, just as a sizing function was used in the Widget system, a fudget will havean associated sizing function:> type SizeFun = Rect -> GUI ()> data Layout = L LayoutRequest SizeFun> data LayoutRequest = Layout Size Bool Bool> nullSizer :: SizeFun> nullSizer rect = return ()> nullLayout :: [Layout]> nullLayout = [L (Layout (0, 0) True True) nullSizer]Layout combinators in the Fudget system essentially convert a list of layout requests into asingle request:> type Placer = [Layout] -> LayoutA fudget is represented as a function taking two arguments. The �rst indicates the windowthe fudget is to be created inside of, and the second is a handler that can be used to outputvalues from the fudget. The result of the function is a value of the GUI monad because thefudget can communicate with the windowing system. The result of the action returned is apair of values, the �rst of which speci�es an input handler that can be used to send inputvalues to the fudget, the second of which is a list of layout requests:> type Handler a = a -> GUI ()> type F a b = Window -> Handler b -> GUI (Handler a, [Layout])> nullHandler :: Handler a> nullHandler a = return ()> nullF :: F a b> nullF parent outputHandler> = return (nullHandler, nullLayout) 82



A fudget program can be executed by converting it into a program using the standard HaskellI/O mechanism and then running it. The fudlogue function performs this conversion, bypassing a null window and null handler to the fudget, and using this as the initialisation forthe startProg function:> fudlogue :: F a b -> IO ()> fudlogue f = startProg (do f nullWindow nullHandler> return ())B.5.2 Layout FudgetsThis module contains functions for specifying the layout of fudget programs.> module LayoutFudgets> where> import EmbracingWindows> import FudgetCore> import Combinators> import LayoutWidgets -- For splitsegsThe part function is useful for dividing a list into two lists determined by a predicate overthe elements of the list. This is used in the de�nition of the horizontalP and verticalPplacers:> part :: (a -> Bool) -> [a] -> ([a], [a])> part p [] = ([],[])> part p (x:xs) = let (ys, zs) = part p xs> in if p x then (x : ys, zs) else (ys, x : zs)The following functions are useful auxillary functions for manipulating layout requests:> fixedh :: LayoutRequest -> Bool> fixedh (Layout _ hf _) = hf> fixedv :: LayoutRequest -> Bool> fixedv (Layout _ _ vf) = vf> minsize :: LayoutRequest -> Size> minsize (Layout size hf vf) = size> getRequest :: Layout -> LayoutRequest> getRequest (L request sizer) = request> getRequests :: [Layout] -> [LayoutRequest]> getRequests layouts = map getRequest layouts> getSizefun :: Layout -> SizeFun> getSizefun (L _ sizefun) = sizefunThe placerF function is used to apply a placer to a fudget. It uses the placer to combinethe list of layout requests associated with a fudget into a single layout request that is used tobuild the new fudget:> placerF :: Placer -> F a b -> F a b> placerF placer f parent outputHandler> = do (inputHandler, layouts) <- f parent outputHandler> return (inputHandler, [placer layouts])83



By reversing the list of layout requests before applying a placer, we can reverse the placersaction, for example converting a horizontalP into a placer that puts fudget next to eachother horizontally from right to left instead of left to right:> revP :: Placer -> Placer> revP placer = placer . reverseTwo commonly used placers are horizontalP and verticalP used to place fudgets next toeach other horizontally and vertically, respectively. We de�ne two functions, hBoxF and vBoxF,that take fudgets as arguments and apply the appropriate placer to make the use of theseplacers easier. The logic behind the horizontalP and verticalP placers is similar to that forthe Widget system placers. Basically, the available space is split between the fudgets wantingthe space according to how much space they each requested. Fudgets that are not willingto accept a change in the space they are given are allocated space �rst, with the remainingspace divided proportionally amongst those fudgets that can accept a change in their size.A transpose combinator is di�cult to write for the same reasons as for the Widget system,that is, the sizing functions need to be split into two separate functions. The �rst of thesefunctions divides allocated screen space amongst fudgets giving a list of rectangles, whilst thesecond function sizes the fudgets using these rectangles. This would be necessary so that thetranspose combinator can modify the list of rectangles produced by the �rst function. Sincethe sizing functions are not broken into two in this way, writing a transpose combinator isdi�cult:> hBoxF = placerF horizontalP> vBoxF = placerF verticalP> horizontalP :: Placer> horizontalP layouts => let requests = getRequests layouts> minsizes = map minsize requests> h = sum (map getX minsizes)> v = (maximum . (0:) . (map getY)) minsizes> (fh', fv') = (allf and fixedh, allf and fixedv)> allf conn fix = conn (map fix requests)> sizer rect => let goth = (fromInt . getX . getSize) rect> gotv = (fromInt . getY . getSize) rect> startx = (fromInt . getX . getPoint) rect> starty = (getY . getPoint) rect> (fih, flh) = part fixedh requests> fixedh' = (fromInt . sum . map (getX . minsize)) fih> floath = (fromInt . sum . map (getX . minsize)) flh> fixedR = if floath > 0.0 then 1.0 else goth / fixedh'> floatR = if floath == 0.0 then 1.0 else (goth - fixedh') / floath> rR' req = if fixedh req then fixedR else floatR> place x [] = [return ()]> place x (l : ls) => let req = getRequest l> sf = getSizefun l> width = (fromInt . getX . minsize) req * rR' req> x' = truncate x> newx = x + width> width' = truncate width> in (sf ((x', starty), (width', gotv)) ) : place newx ls> in sequence (place startx layouts)> in (L (Layout (h, v) fh' fv') sizer) 84



> verticalP :: Placer> verticalP layouts => let requests = getRequests layouts> minsizes = map minsize requests> h = sum (map getY minsizes)> v = (maximum . (0:) . (map getX)) minsizes> (fh', fv') = (allf and fixedv, allf and fixedh)> allf conn fix = conn (map fix requests)> sizer rect => let goth = (fromInt . getY . getSize) rect> gotv = (fromInt . getX . getSize) rect> startx = (fromInt . getY . getPoint) rect> starty = (getX . getPoint) rect> (fih, flh) = part fixedv requests> fixedh' = (fromInt . sum . map (getY . minsize)) fih> floath = (fromInt . sum . map (getY . minsize)) flh> fixedR = if floath > 0.0 then 1.0 else goth / fixedh'> floatR = if floath == 0.0 then 1.0 else (goth - fixedh') / floath> rR' req = if fixedv req then fixedR else floatR> place y [] = [return ()]> place y (l : ls) => let req = getRequest l> sf = getSizefun l> height = (fromInt . getY . minsize) req * rR' req> y' = truncate y> newy = y + height> height' = truncate height> in (sf ((starty, y'), (gotv, height')) ) : place newy ls> in sequence (place startx layouts)> in (L (Layout (v, h) fv' fh') sizer)A space fudget has no behaviour but does take up screen space, and is willing to change it'ssize to �t the available space:> spaceF :: Size -> F a b> spaceF (w, h) parent outputHandler> = return (nullHandler, [(L (Layout (w, h) False False) nullSizer)])Margins can be added to fudgets using the following layout combinators. The �rst adds amargin to the top and bottom of a fudget, whilst the second adds a margin to the left andright of a fudget. The last adds a margin all the way around a fudget by using a combinationof the �rst two combinators:> vmarginF :: Int -> F a b -> F a b> vmarginF m f = vBoxF (spaceF (0, m) >*< f >*< spaceF (0, m))> hmarginF :: Int -> F a b -> F a b> hmarginF m f = hBoxF (spaceF (m, 0) >*< f >*< spaceF (m, 0))> marginF :: Int -> F a b -> F a b> marginF m f = hmarginF m (vmarginF m f)The noStretchF function allows the stretchability of fudgets in both the horizontal andvertical dimensions to be changed:> noStretchF :: Bool -> Bool -> F a b -> F a b> noStretchF fh fv f parent outputHandler 85



> = do (handler, layout) <- f parent outputHandler> let layout' = map fixStretch layout> return (handler, layout')> where fixStretch (L (Layout size _ _) sizer) = L (Layout size fh fv) sizerCombinator layout is implemented in terms of placer layout, using the three placers horizontalP,verticalP and revP:> data Orientation = Above | Below | RightOf | LeftOf> place2F :: (a -> b -> F c d) -> (a, Orientation) -> b -> F c d> place2F (><) (f1, a1) f2 = placerF (placer a1) (f1 >< f2) where> placer LeftOf = horizontalP> placer RightOf = revP horizontalP> placer Above = verticalP> placer Below = revP verticalP> (>+#<) :: (F a b, Orientation) -> F c d -> F (Either a c) (Either b d)> (>+#<) = place2F (>+<)> (>==#<) :: (F a b, Orientation) -> F c a -> F c b> (>==#<) = place2F (>==<)> (>*#<) :: (F a b, Orientation) -> F a b -> F a b> (>*#<) = place2F (>*<)Fudgets can be placed in a grid formation by using the matrixF function. This function takesthree arguments. The �rst speci�es the width of the grid in terms of fudgets, the secondargument is the fudget combinator to use to combine the fudgets, while the last argument isthe list of fudgets to use to �ll the grid. This layout combinator has a disadvantage as it iscurrently de�ned, as the type of its second argument restricts the fudget combinators thatcan be used to connect the fudgets comprising a matrix:> matrixF :: Int -> (F a b -> F a b -> F a b) -> [F a b] -> F a b> matrixF n (><) fs = let rows = map (foldr1 colop) (splitsegs n fs)> in foldr1 rowop rows> where colop f1 f2 = place2F (><) (f1, LeftOf) f2> rowop f1 f2 = place2F (><) (f2, Below) f1A fudget is realised inside of a window using the shellF function. This function creates a newwindow and realises the fudget inside of it using the horizontalP placer to provide defaultlayout. The layout request of the fudget is used to obtain the desired size for the window.This is used to set the size of the new window. The size for the new window is however,slightly larger than one would expect to account for the size of window borders and menus.The sizing function for the fudget is called to ensure that the fudget is sized appropriately forthe new window. An event handler is installed de�ning the behaviour in response to sizingevents to call the sizing function. Finally the newly created window is made visible, and adummy return input handler and layout request are returned:> shellF :: String -> F a b -> F c d> shellF title f parent outputHandler> = do win <- mkWindow title> (_, l) <- (placerF horizontalP f) win nullHandler> let [(L (Layout (x', y') _ _) sizer)] = l> setWindowRect win ((0, 0), (x' + window_extra_x, y' + window_extra_y))> sizer ((0, 0), (x', y')) 86



> onSize win (\w state xy -> sizer ((0, 0), xy))> showWindow True win> return (nullHandler, nullLayout)B.5.3 Standard FudgetsThis module de�nes a library of standard fudgets, such as push button fudgets, editable text�eld fudgets, and text label fudgets.> module FudgetLib> where> import EmbracingWindows> import FudgetCoreA useful fudget is one that forces the fudget program to quit when it receives any value onits input stream:> quitF :: F a b> quitF parent outputHandler> = return (inputHandler, nullLayout)> where inputHandler a = do quitApp> return ()A push button fudget can be created by the buttonF fudget which takes two arguments, thetext label for the button, and the initial size of the button. The code to create the fudget issimilar to the buttonW function from the Widgets system:> data Click = Click> buttonF :: String -> Size -> F Click Click> buttonF text (w, h) parent outputHandler> = do btn <- mkPushButton parent text ((0, 0), (w, h))> onChange btn (outputHandler Click)> let inputHandler a = outputHandler Click> sizer size = setRect btn size> layout = [(L (Layout (w, h) False False) sizer)]> return (inputHandler, layout)A timer fudget outputs the value Tick at prede�ned time intervals:> data Tick = Tick> timerF :: F (Maybe (Int, Int)) Tick> timerF parent outputHandler> = do return (inputHandler, nullLayout)> where inputHandler Nothing = killTimer parent 0> inputHandler (Just (interval, delay))> = do setTimer parent 0 interval> onTimer parent (\w id -> outputHandler Tick)An editable text �eld fudget can be created with the stringF function. This uses the datatype InputMsg to indicate on its output stream any changes that occur to the edit �eld, suchas a simple change, or a commit:> data InputMsg a = InputChange a |> InputDone a> deriving (Eq, Ord, Show)87



> stringF :: Size -> F String (InputMsg String)> stringF (w,h) parent outputHandler> = do edit <- mkEditField parent "" ((0, 0), (w, h))> let outputHandler' output = do str <- getText edit> outputHandler (output str)> onChange edit (outputHandler' InputChange)> onCommit edit (outputHandler' InputDone)> let inputHandler a = setText edit a> sizer size = setRect edit size> layout = [(L (Layout (w, h) True True) sizer)]> return (inputHandler, layout)The intDispF function creates a fudget showing the value of an integer. The value beingdisplayed can be changed by sending the new value on the fudget's input stream:> intDispF :: Size -> F Int a> intDispF (w,h) parent outputHandler> = do lab <- mkTextLabel parent "" ((0, 0), (w, h))> let inputHandler a = setText lab (show a)> sizer size = setRect lab size> layout = [(L (Layout (w, h) True True) sizer)]> return (inputHandler, layout)The labelF function creates a fudget showing a text label. The text label can be changed bysending a new text label on the fudget's input stream:> labelF :: String -> Size -> F String b> labelF text (w, h) parent outputHandler> = do lab <- mkTextLabel parent text ((0, 0), (w, h))> let inputHandler a = setText lab a> sizer size = setRect lab size> layout = [(L (Layout (w, h) True True) sizer)]> return (inputHandler, layout)B.5.4 Stream processorsThis module de�nes a representation for stream processors along with the three basic streamprocessor, putSP, getSP and nullSP.> module SP where> import FudgetCore> type SP a b = F a b> putSP :: a -> SP b a -> SP b a> putSP init f parent outputHandler> = do (inputHandler, _) <- f parent outputHandler> outputHandler init> return (inputHandler, nullLayout)> getSP :: (a -> SP a b) -> SP a b> getSP f parent outputHandler> = return (inputHandler, nullLayout)> where inputHandler a = do f a parent outputHandler> return () 88



> nullSP :: SP a b> nullSP parent outputHandler> = return (\a -> return (), nullLayout)B.5.5 Stream Processor CombinatorsThis module de�nes some useful combinators for building complex stream processors, alongwith equivalent in�x operators.> module SPCombs> where> import Combinators> import SP> import SPOps> infixr 6 >^^=<> infixl 6 >=^^<> infixr 6 >^=<> infixl 6 >=^<> serCompSP :: SP b c -> SP a b -> SP a c> serCompSP = (>==<)> parSP :: SP a b -> SP a b -> SP a b> parSP = (>*<)> compSP :: SP a b -> SP c d -> SP (Either a c) (Either b d)> compSP = (>+<)> absF :: SP a b -> F a b> absF x = x> (>^^=<) :: SP b c -> F a b -> F a c> sp >^^=< fud = absF sp >==< fud> (>=^^<) :: F b c -> SP a b -> F a c> fud >=^^< sp = fud >==< absF sp> (>^=<) :: (b -> c) -> F a b -> F a c> f >^=< fud = mapSP f >^^=< fud> (>=^<) :: F b c -> (a -> b) -> F a c> fud >=^< f = fud >=^^< mapSP fB.5.6 Stream Processor OperationsThis module de�nes functions for constructing useful stream processors.> module SPOps> where> import SP> import FudgetLib> import MutVarThe identity stream processor simply passes all values that arrive on its input stream to itsoutput stream. A mapping stream processor takes a function that speci�es how to generateoutput stream elements from input stream elements:89



> idSP :: SP a a> idSP = getSP (\x -> putSP x idSP)> mapSP :: (a -> b) -> SP a b> mapSP f = getSP (\x -> putSP (f x) (mapSP f))The mapAccumlSP function constructs a stateful stream processor as described in Section 4.4:> mapAccumlSP :: (a -> b -> (a, c)) -> a -> SP b c> mapAccumlSP f init parent outputHandler> = do stateVar <- newRef init> return (inputHandler stateVar, nullLayout)> where> inputHandler stateVar a = do s <- getRef stateVar> let (s', b) = f s a> setRef stateVar s'> outputHandler bThe following stream processor �lters input stream values to the output stream according tothe �lter function speci�ed as the �rst argument:> mapFilterSP :: (a -> Maybe b) -> SP a b> mapFilterSP f> = getSP (\x -> case f x of> Just y -> putSP y (mapFilterSP f)> Nothing -> mapFilterSP f)The inputDoneSP stream processor is useful for testing whether an editable text �eld fudgethas had its value commited or not:> inputDoneSP :: SP (InputMsg a) a> inputDoneSP = mapFilterSP done> where> done (InputDone s) = Just s> done _ = NothingThe following functions are useful for dealing with editable text �eld fudgets:> stripInputMsg :: InputMsg a -> Maybe a> stripInputMsg (InputDone x) = Just x> stripInputMsg (InputChange x) = Just x> stripInputSP :: SP (InputMsg a) a> stripInputSP = mapFilterSP stripInputMsg> tstInp :: (a -> b) -> InputMsg a -> b> tstInp p (InputChange s) = p s> tstInp p (InputDone s) = p s> mapInp :: (a -> b) -> InputMsg a -> InputMsg b> mapInp f (InputChange s) = InputChange (f s)> mapInp f (InputDone s) = InputDone (f s)B.5.7 Fudget CombinatorsThis module de�nes in�x operators for combining fudgets.90



> module Combinators where> import FudgetCore> infixr 4 >==<> infixl 5 >*<> infixl 5 >+<The (>==<) operator combines two fudgets in series:> (>==<) :: F a b -> F c a -> F c b> (f1 >==< f2) parent outputHandler> = do (handler, lra) <- f1 parent outputHandler> (inputHandler, lrb) <- f2 parent handler> return (inputHandler, lra ++ lrb)The (>*<) operator combines two fudgets in parallel, with the values on the input and outputstreams being untagged:> (>*<) :: F a b -> F a b -> F a b> (f1 >*< f2) parent outputHandler> = do (handler, lra) <- f1 parent outputHandler> (inputHandler, lrb) <- f2 parent outputHandler> let compInputHandler a = do handler a> inputHandler a> return ()> return (compInputHandler, lra ++ lrb)The (>+<) operator combines two fudgets in parallel, tagging the values on the input andoutput streams:> (>+<) :: F a b -> F c d -> F (Either a c) (Either b d)> (f1 >+< f2) parent outputHandler> = do (handler, lra) <- f1 parent (outputHandler . Left)> (inputHandler, lrb) <- f2 parent (outputHandler . Right)> let compInputHandler a = do case a of> Left v -> handler v> Right v -> inputHandler v> return ()> return (compInputHandler, lra ++ lrb)B.5.8 Fudgets SystemThis module imports all of the source code that forms the fudget system.> module Fudgets> where> import FudgetCore> import LayoutFudgets> import FudgetLib> import SP> import SPCombs> import SPOps 91
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